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1 Introduction
Welcome to Ekahau Site Survey (ESS). ESS is a tool for deploying and maintaining high-perform-
ance 802.11 Wi-Fi networks. This user guide is designed to help you to understand and make use
of the many features of Ekahau Site Survey and demonstrate how these features can benefit you
in the design, deployment and troubleshooting of Wi-Fi networks.

Note

Do not operate Ekahau Site Survey and drive or carelessly walk at the same time. Stop using
ESS and switch off the Wi-Fi device when it is forbidden to use radio equipment or when it may
cause interference or danger.

1.1 Overview
Deploying and maintaining wireless networks offers many challenges beyond those of traditional
wired networks. Because of the unpredictable and invisible nature of wireless, visual, professional
tools are needed to achieve high performance. In order to support the business requirements of
the organization, several important factors need to be considered:

● Wi-Fi is invisible: it is hard to make a clear picture of how far your network will reach and how
it will work in different locations.

● Wireless is fluctuating and unpredictable: Whereas wired networks can be said to operate in
a predictable way over a long period of time, wireless connections may work differently at any
given time, depending on the conditions.

● Wireless is ubiquitous: Whereas a wired Ethernet only has a certain number of connection
points, wireless access points can host numerous simultaneous connections, offering con-
nectivity over great distances.

● Capacity planning is fairly straightforward in wired networks . However, wireless is a shared
medium where the overall capacity is shared by multiple users at any given time.

For these and many other reasons, proper tools are required when designing, deploying, maintaining
and troubleshooting Wi-Fi networks. Ekahau Site Survey is a state-of-the-art tool that makes Wi-
Fi understandable and allows you to get the best out of your Wi-Fi network.

1.2 Features
Ekahau Site Survey is designed for use throughout the life cycle of your Wi-Fi network. Whether
you are in the planning, deployment, verification, or troubleshooting phase, ESS has features to
assist you. The key features of ESS are:

● Automated Network Planning: Automatically determine the optimal the number and location
for your access points prior to physical deployment (Ekahau Site Survey Pro only)

● Verification: Perform active and passive indoor and GPS assisted outdoor site surveys to
verify coverage and performance (GPS support in Ekahau Site Survey Pro only)

● Analysis and Optimization: Visualize network coverage, capacity, and performance, fine-
tune them, and simulate changes in the network or environment

● Troubleshooting: Solve various Wi-Fi issues
● Reporting: Generate reports of Wi-Fi coverage and performance (Ekahau Site Survey Pro

only)
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1.2.1 Feature Differences Between Professional and Standard
Ekahau Site Survey Standard includes tools for network verification, analysis, optimization, and
troubleshooting. Ekahau Site Survey Professional version includes all the features in Standard,
plus the following features:

● Automated Network Planning: Design a network off-site in 3D. Also enables planning for
extended coverage or capacity for an existing network

● Network Capacity Analysis:With the increasing number of smartphones, laptops, and tablets
constantly utilizing Wi-Fi networks, capacity needs to be considered during network design,
verification, and troubleshooting

● Automated Reporting: Automatically generates comprehensive network documentation,
including coverage and performance maps, network infrastructure layout and configuration,
and other information

● GPS Enabled Outdoor Site Surveys: For performing outdoor site surveys without clicking
on the map using a GPS receiver (GPS receiver not included)

● Cisco Prime NCS / WCS Integration: Complete integration with Cisco Prime NCS / WCS -
Import your floor plans directly from Cisco Prime - Export both your planning and real-world
survey project to Cisco NCS / WCS

1.3 Technical Support
Ekahau provides technical support free of charge for all customers for 30 days. Customers who
have purchased Ekahau Support will receive Ekahau Support services for 12 months from the
date of purchase.

Ekahau Support includes:

● All upgrades and patches for the product(s) and documentation purchased
● Free-of-charge support via Ekahau Technical Support Portal at http://www.ekahau.com/support

(preferred) and telephone during regular business hours (PST, EST, GMT+2)

Bug fix patches are free of charge for all customers.

To renew your Ekahau Support, please contact your Ekahau representative or sales@ekahau.com.

1.4 Backward Compatibility
Ekahau Site Survey is backwards compatible with the following Ekahau products:

1.4.1 Compatibility with previous Ekahau Site Survey versions
● The Ekahau Site Survey 5.6 is able to open older project files (.esx). ESS 5.6 can open files

created with any previous Ekahau Site Survey 2.x, 4.x, or 5.x version.
● Previous ESS 5.x versions can open ESS 5.6 project files
● Older ESS 4.x versions are not able to open ESS 5.6 project files.
● RTLS Compatibility: Projects created or modified with ESS 5.6 will require Ekahau RTLS

Controller 5.0 or newer
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1.4.2 License compatibility with previous Ekahau Site Survey
versions
Ekahau Site Survey 5.6 and later versions require a new license that is not compatible with previous
Ekahau Site Survey versions (ESS 5.5 or older). If you have a valid Ekahau Site Survey Support
package, but you have not received a new Ekahau Site Survey 5.6 license, please contact Ekahau
Technical Support at http://www.ekahau.com/support or your Ekahau Sales representative.
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2 Installation

2.1 System Requirements and Software Limitations

The following hardware and operating system are required to run the program:

● Windows 7 (64 bit & 32 bit) , Vista (64 bit & 32 bit), or XP (32 bit only) Operating System
● 1+ GB RAM, 2GB+ RAM recommended for large projects
● 1GB free hard disk space
● A supported Wi-Fi adapter (visit http://www.ekahau.com/devices)
● Laptop computer (required for recording surveys, a desktop computer is sufficient planning

and analysis)
● Screen resolution of 1024 x 768 or higher, 32-bit color quality recommended

Note

Ekahau recommends Windows 7 OS (64 bit) with 4GB RAM for project larger than 300,000
square feet.

The following is required for simultaneous active and passive surveys (Hybrid Surveys):

● Supported external Wi-Fi adapter for traditional passive surveys
● Integrated Wi-Fi adapter for end-to-end connectivity testing
● Network connection via the Integrated Wi-Fi adapter using Windows Wi-Fi management tool

(Disable the third party Wi-Fi connectivity tool if enabled!)

Please consider the following limitations that apply to the program:

● The software may become unstable if a single Project file contains more than 10 000 access
point MAC addresses

● The software supports map images with 10000 x 5000 pixels and smaller
● The software may become unstable if more than 100 hours of survey data is recorded into a

single Project

Note

USB Wi-Fi adapters are not fully supported in Windows XP OS. To take full advantage of Ekahau
Site Survey in laptop with Windows XP OS, Ekahau recommends using Ekahau NIC-300-
Cardbus Wi-Fi adapter.

2.1.1 Supported Wi-Fi Adapters
Ekahau Site Survey supports most common 802.11 Wi-Fi network adapters for conducting surveys
regardless the card type. A wireless network adapter is not required if you do not wish to record
signal data such if you just want to use the automated network planning feature.
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Please visit our website for the complete list of supported Wi-Fi adatpers:

http://www.ekahau.com/devices

The Ekahau Site Survey can conduct surveys in traditional passive mode as well as in active
mode. When these surveys are conducted simultaneously, we call this as Hybrid Survey. The
Hybrid Survey requires two Wi-Fi adapters to be used at the same time:

● An external Wi-Fi adapter (such as Ekahau NIC-300-Cardbus or NIC-300-USB) for Passive
Survey

● An integrated Wi-Fi adapter for end-to-end connectivy testing in Active Survey

Warning

Intel Centrino Laptops with the built-in Wi-Fi chipset can be used for passive site surveys (RSSI
measurement). However, since the measurement accuracy and network scanning speed is not
optimal for passive site surveys, it is recommended to use a third-party network adapter, such
as Ekahau NIC-300-Cardbus or NIC-300-USB instead for the passive site survey measurements.

2.2 How to Install

1. Make sure you have a supported network adapter inserted into your laptop (visit
http://www.ekahau.com/devices for a list of supported adapters)

2. Double-click the executable file (.exe file) to start installation
3. Follow the on-screen instructions given by the Installation Wizard to install ESS
4. Follow the on-screen instructions to install Wi-Fi adapter driver and Ekahau Wireless Utility

(see below for details)

2.2.1 Wi-Fi Network Adapter Driver Update

The external Wi-Fi adapter driver needs to be updated in order to collect signal measurements.
The Wi-Fi adapter driver will be updated automatically during the installation.

Make sure you have a supported Wi-Fi adapter inserted when installing the product. Skip driver
installation if you do not wish to conduct Surveys, or do not have a supported external wireless
network adapter available at the time of the installation.

Note

If you did not have a supported adapter at the time of the installation (or if you chose to install
the driver later for some other reason), you can install the WLAN adapter driver and the wireless
connection utility later by selecting the Install Cardbus/USB Wi-Fi Adapter Driver from the
program folder in the Start menu.
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Note

It is also highly recommended to update the integrated Wi-Fi adapter's driver if used for either
passive survey or active survey.

For Windows XP, the driver installation will also install the Ekahau Wireless Utility for managing
the wireless connectivity. The Wireless Utility can be started from the Start menu. For more
information, please use the help features in the Wireless Utility user interface. You may also choose
to only install the driver and skip the Wireless Utility installation if you want to continue using a
third party wireless utility.

If you wish to stop using the program, and thus also the customized network adapter driver, simply
run the Wi-Fi Adapter Driver Installer from the Start menu again, and select Uninstallation.

2.2.2 Upgrading the Ekahau Site Survey License

The first time you start the software, you will be prompted for a license key. If you are evaluating
the software, you do not need a license.

If you have purchased the product, you should have received the license key via e-mail. When
prompted, type in the license key, as well as your name and company.

The software license will be tied to a selected network adapter. When starting the software, you
will need to select the network adapter you wish to pair the license key with. The network adapter
does not need to be a Wi-Fi adapter, you can pair the license with a fixed Ethernet adapter also
- the network adapter just needs to be present when the software is started. The adapter you select
at this point does not limit what Wi-Fi cards can be used with the tool.

After inserting the license, the tool will register the MAC address and the license key on-line. For
this, an internet connection is required when starting the software for the first time.

If you wish to continue in the evaluation mode and upgrade the license later, go to Help > About
and select Upgrade License.

Note

After registering the software, the network adapter will be checked every time the software is
started. If the network adapter is removed or disabled, the software will not start.

The evaluation license has several limitations. For evaluating the product for network design and
site surveys, the limitations are:

● Network planning is time-limited to 15 minutes
● Surveying is limited to 15 minutes
● Opening (except the Example Project), merging, reporting, and saving are disabled
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3 Designing, Deploying and Troubleshooting Wi-Fi
Networks

Below is shown a typical example on how high-quality wireless networks are designed, deployed
and managed using Ekahau Site Survey. Network deployment strategies may vary, but most of
the network deployments include several of the following steps:

1. Define the Requirements
Determine what applications and the anticipated number of users the network will host.
Determine service areas, network security policies,end user devices, funding and scheduling.
From these, define the network coverage, capacity, performance,compatibility, and security
requirements. Conduct a visual site inspection.
In Ekahau Site Survey, you define the network requirements by selecting the type of application
used in the network, such as “data” or “voice over IP”. You can also create your own custom
network requirements. The requirements can be edited from Site > Edit Requirements .
Once the requirements for your network have been defined, you can easily compare the net-
work (simulated or measured) against the requirements using the Network Health visualization.

2. Automatically Create the Network Plan with Auto-Planner (Ekahau Site Survey Pro only)
Use the ESS Auto-Planner to create a network plan for you automatically. The Auto-Planner
automatically computes the optimal access point locations and configurations without going
on-site. ESS can visualize predicted coverage and performance, based on your requirements.
In addition, you can manually adjust the AP locations and configurations or just manually
create the complete network plan with simulated access points if needed.

3. Perform Pre-Deployment Site Survey
The goal of the pre-deployment survey is to verify the accuracy of the network plan prior to
purchasing and installing all the equipment. By performing pre-deployment site surveys, you
can be more confident of the number of APs and that their installation locations are optimal.
During the pre-deployment survey, you will also find all the third-party or rogue access points
that may be radiating to the facility.
When on site, power up an access point in one of the location defined in the Network Plan
phase. Perform a site survey in the coverage area of the AP. Use the Freeze Access Point
feature, and move the access point to the next location. Repeat this process for all the APs
planned in the network design. The end results is a site survey of the whole facility, without
having to purchase all the necessary network equipment.

4. Fine-tune the Network Design
If the network meets your requirements, you can directly proceed to the next step. If the network
does not meet the requirements, fine-tune the configuration using the simulation capabilities
ESS in until it does.

5. Deploy the Network Infrastructure
Based on the network plan, and the pre-deployment site surveys, deploy the wireless network
infrastructure. Use ESS to store notes about the installation.

6. Conduct a verification survey
Verify the network coverage and performance by conducting a site survey throughout the
entire site.

7. Analyze and fine-tune to finalize the network design
Analyze the network coverage, performance, and capacity. If the verification survey reveals
that the network still does not meet the network performance and capacity requirements, fine
tune and re-survey until it does. Use the simulation and optimization features of ESS to perfect
the network.

8. Create documentation (Ekahau Site Survey Pro only)
Use the reporting feature to create complete documentation of the network installation, cover-
age, and performance with the click of a button.

9. Troubleshooting, Monitoring, Maintenance, Expansion

Chapter 3. Designing, Deploying and
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Problems do occur that cannot be “seen” from the Wi-Fi Controller, but have to be investigated
on the client side. Use Ekahau Site Survey in combination with your Wi-Fi Controller to keep
your wireless network up and running. Use the Live Network Status feature to quickly detect
and solve basic Wi-Fi issues such as finding defective and / or missconfigured Wi-Fi Access
Points. Conduct periodic site surveys to ensure flawless operation. Design for additional
coverage or performance using the network planning features by simply opening the surveyed
project file, and adding simulated access points on the surveyed data.

3.1 Ekahau Site Survey and Other Wi-Fi Tools
Ekahau Site Survey is a comprehensive tool that assists during the entire life cycle of a Wi-Fi
network. However, there are other tools available that are complementary and worth considering
also:

● Wi-Fi Management softwares are designed to assist in the set-up, monitoring and manage-
ment of the network. While Wi-Fi controllers assist you in setting up the network configurations
and monitoring the network on a high level, site survey tools can provide more detailed
information not visible to the Wi-Fi controller. Some scenarios that ESS can solve are: Broken
APs, unsuccessful configuration updates to the APs, rogue APs beyond the reach of your Wi-
Fi APs, and coverage holes not detected by your APs. In addition, Ekahau Site Survey provides
state-of-the-art tools for network planning and expansion whereas some controllers may
provide basic tools for "ballpark" type network planning.

● Spectrum Analyzers help understand the radio frequency in more detail. Whereas Ekahau
Site Survey provides a view to the audible Wi-Fi signals, a spectrum analyzer shows the non-
Wi-Fi interference: It allows you to solve problems caused by such interfering devices as
microwave ovens, wireless video cameras, and baby monitors. Ekahau recommends using
Ekahau Spectrum Analyzer which can be purchased together with Ekahau Site Survey. To
purchase the the Ekahau Spectrum Analyzer, please contact Ekahau Sales at sales@eka-
hau.com.

● Packet Analyzers (Protocol Analyzers) solve issues that are not related to the Wi-Fi signals,
but lie in the packet level. You can figure out exactly what kind of packets are being sent and
received, and detect otherwise hard-to-detect problems, such as issues related to AP/Client
configuration or incompatibility between the devices. Ekahau recommends using WildPackets
OmniPeek packet analyzer.
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4 User Interface Overview
Figure 4.1. User interface overview

1. Access Point, Survey list, and Building view tabs
2. Toolbar
3. Visualizations Selections
4. Miniature Requirement view - Displays how the network perform against the requirements at

a glance
5. Miniature Ping view - The digits on the top left are the last digits of the associated AP MAC

address
6. Miniature Signal view
7. Spectrum analyzer quick launch
8. Planning and Survey tabs
9. Map view

4.1 Map View
The map view is the most commonly used view in ESS. Use the map view to:

● Create network plans
● Perform site surveys
● Place and move access points
● Analyze and optimize the network coverage and performance

Zooming the map is done using the zooming buttons in the toolbar, using the mouse wheel, or
from the View menu. You can also zoom by right-clicking on the map when using the Edit, Simulated
Access Point, and Wall tools.
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Figure 4.2. ESS map view

1. Select and add map
2. Drawing walls is not required if network planning is not used
3. An 802.11g access point on channel 1
4. Survey route - Arrows indicate survey direction
5. Visualization Legend - Click to adjust visualization value range and color scheme

4.2 Planning and Survey Tabs
Use the Planning and Survey tabs to access the most commonly used tools:
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The Planning Tab

These tools are needed when working with a predictive design of a Wi-Fi network.

DescriptionNameIcon

Edit Items on the Map. Allows you to perform various functions to items
on the map, such as move and delete.

Edit

Indicate Scale. Indicate the scale of the map. Can also be used as a
distance measurement tool.

Scale

Place a Simulated Access Point on the Map. Optionally select the
properties of the AP prior to placing it.

Simulated
Access Point

Place a Floor Alignment Point. Aligns the floor with the neighboring
floors. Only needed when the 3D planner is used.

Floor Alignment

Draw Walls. Only needed when the 3D planner is used.Wall

Indicate Coverage Areas for Auto-Planner. Draw areas where you
want Auto-Planner to provide Wi-Fi coverage and to place access points.

Coverage Area

Open Auto-Planner. Click to open the Auto-Planner configuration dialog
and configure the Auto-Planner.

Auto-Planner

The Survey Tab

Survey - These tools are needed when performing site surveys or troubleshooting the network

DescriptionNameIcon

Edit items on the map. Allows you to perform various functions to items
on the map, such as move and delete.

Edit

Indicate Scale. Indicate the scale of the map. Can also be used as a
distance measurement tool.

Scale

PerformSurveys:Record signal measurements around the facility. Enable
the tool, and walk around the map while clicking on your current location
when you stop, start walking or change direction. If you check the Auto-
Place APs After Survey checkbox, the access points will be automatically
located after the survey.

The GPS Record button is used for performing GPS assisted outdoor
surveys.

Record Survey

Inspect surveyed data in detail. Click on the tool, and you will see the
surveyed measurements on the map. Double click on the measurement
to see measurement details.

Survey Inspector

Place GPS Reference Points on the map. Without the reference points,
the GPS coordinates cannot be converted to map coordinates, and thus
the GPS information cannot be displayed on the map.

GPS Reference
Point Tool
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DescriptionNameIcon

Displays the currently measured signal strength (green) and noise
(red) values. Click to access the Live Network Status view. Shows "No
Devices" if no devices are present.

Miniature Signal
View

Change Network Adapter Settings: Click on the network adapter to
change its settings or to select a different adapter to be used.

Network Adapter
Setting

End-to-end Testing: Click to configure the host that is being used for
end-to-end network connection testing and to access the Live Network
Status Ping view

Miniature Ping
View

Displays how the network performas against the requirements: Each
criterion that passes the requirement is displayed with green bar where
as the failing criterion is shown with red bar - Click to change the require-
ment

Miniature
Requirement
View

4.3 Visualization Selections
You can select the visualization by adjusting the two drop-down menus at the top of the screen -
one selects the visualization and the other selects the access points to show the visualization for.
More about visualizations in chapter Analyzing the Wi-Fi Coverage and Performance on page 59.

4.4 Toolbar

The toolbar includes the icons for the most common actions:

DescriptionNameIcon

Open a ProjectOpen

Save the ProjectSave

Generate a Report in PDF or RTFReport

Zoom in to see an area in more detailZoom In

Zoom out to see a wider area of the map at onceZoom Out

Fit the map into the windowZoom to Fit

Zoom to see the map in its actual pixel sizeZoom 1:1

4.5 The Access Point List
Both simulated and measured access points are listed in the Access Point List on the left-hand
side of the screen. The access points are grouped by floor. Only the access points on the floor
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you are currently viewing are displayed by default. To see APs on other floors, click on the floor
name to see the APs for that floor.

Figure 4.3. Access point list view

1. Search for specific AP(s) such as all APs manufactured by D-Link
2. Quickly select a group of APs
3. There are 12 APs on this floor, out of which 3 are shown
4. Perform actions to APs: Select All/None, Freeze, Join, Automatically Place APs on map, Edit
5. This AP is selected (Notice the orange color)
6. This AP is selected - Click here to select or de-select

4.5.1 Selecting Access Points

There are several methods to select which access points to visualize, edit, or select as My APs.

APs can be selected one by one either from the map or from the AP list:

● To select APs on the map, simply click on the AP to be selected. Click on the AP again to
de-select it. The selected AP will be highlighted on the map, and in the AP list.

● To select APs on the AP List, click on the handle on the left-hand side of the AP list to select
an AP - an orange color will indicate that the AP has been selected. Click on the handle again
to de-select. You will also see the AP being highlighted on the map.

Simulated APs can be selected in the same way as measured APs. However, simulated multi-
radio APs can be selected one radio at a time:
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● To select radios on the map, click on the rectangle on the right-hand side of the AP. The
rectangle will become highlighted with orange when it is selected.

● To select radios on the AP List, click on the handle on the left-hand side of the radio prop-
erties field.

Figure 4.4. Selecting one radio at a time

Selecting Multiple Access Points at Once

To select multiple access points at once, you have two options:

● To select all the access points, choose Actions > Select All. Please note that if a search
is used, this action will only select all the searched access points. To deselect all access
points, select Actions > Select None.

● To quickly select the APs with a given SSID, channel, or band , click Quick Select, and
click on the SSID, channel or band to select only the appropriate APs. You can also select
only simulated or measured access points. If you select multiple criteria, such as SSID and
band, only the access points matching all the criteria will be selected.

Figure 4.5. Access Point Quick Selection
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4.5.2 Searching for Access Points

Use the Search text box to search one or more APs. Only the APs matching the search criteria
will be displayed. To display all access points, either delete the search field or click on the X button
next to the search field. The following search options are available:

DescriptionExample Search Terms

Search by a partial or complete MAC address00:17:0f, 00:17:0f:12:ab:a1

Search by the name of the AP. The name is defaulted
to the vendor with measured access points.

Nortel, Siemens, Simulated AP 4

Search by the SSID the AP is onguest, tsunami

Search by the 802.11 standard the AP supports802.11a, 802.11b

Search only the APs selected as Mymy

Search only the APs not selected as Myother

4.5.3 Visualizing Selected Access Points

You can limit the access points to be included in the heat map visualizations from the drop-down
menu next to the Visualization Selection menu.

● Showing the visualization for All Access Points displays the visualization (heat map) using
the information from all the access points. For example, if you want to see the total number
of access points on a given map, select Show Number of APs for All Access Points

● If My Access Points is selected, the visualizations will only be shown using the data of the
access points checked as My from the AP List. For example, if you want to see the coverage
area of your network, select Show Signal Strength for My Access Points. Selecting All
Access Points instead of My Access Points would include neighboring and rogue access
points, and thus overly optimistic results would be displayed.

● Having Other Access Points selected is the exact opposite for selecting My Access Points.
For example, if you want to show the signals from access points that are not in your network,
select Show Signal Strength for Other Access Points.

● If Selected Access Points is selected, only the access points that have been selected in the
Access Points list will be taken into account into the visualization. For example, if you wanted
to see the coverage area of a single access point, first highlight that access point from the
AP list, and then select Show Signal Strength for Selected Access Points. See the example
picture below.
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Figure 4.6. Visualizing only selected access points

1. In the example, ESS visualizes only those APs that are selected (notice the orange color)

4.5.4 Selecting My Access Points

During the site survey, all the audible access points will be detected. It is important to segregate
the access points in your network from the other access points, such as the APs radiating from
the nextdoor building. The My checkbox in the AP list indicates whether an AP is in your network
or not.

You can select My APs either one by one, or by selecting multiple access points first and then
selecting or de-selecting the My checkbox to select or de-select multiple APs to/from My APs. For
example, if you have Nortel APs (and there are no other Nortel APs around):

1. De-select all the APs from My selection: Click Actions > Select All and then choose Actions
> Deselect from My. Now none of the APs are selected as My.

2. Next, type "Nortel" into the Search text box
3. then click Actions > Select All to select all the Nortel APs.
4. To select all the searched Nortel APs as My, click Actions > Select as My, and all the Nortel

APs will now be selected as My.

4.5.5 Renaming Access Points

By default, the measured access points are named by the AP brand, such as Nortel, Cisco or
Siemens. The simulated APs are named using running numbers by default. To rename the APs,
simply click on the name field, and type in a custom AP name.
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4.5.6 Replacing Access Points
If an access point breaks down, there is no need to perform a new survey. There are two options
you can do:

● If the access point is replaced by another, identical AP in the same location: In the AP
List, click on the MAC address of the access point and select Replace MAC, and type in the
MAC address of the new access point to the Replacing MAC field.

Figure 4.7. When replacing access points, remember to select the correct Vendor setting (if
not selected by default) to ensure that the multi-MAC access points are replaced correctly.

● If the access point is not replaced by an identical AP: Deselect the access point form the
My Access Points using the Surveys list.

Note

If the access point is replaced by another AP, but not with an identical one, you need to perform
a new survey within the coverage area of the new access point.

4.5.6.1 Replacing Single-MAC and Multi-MAC Access Points
When replacing access points distributing just one MAC address, use the "Generic - one
MAC replaced" Vendor option.

In case of Multi-MAC access points (APs that are sending out one MAC per SSID), ensure that
the vendor has been selected correctly to apply the changes to the whole MAC range of the AP.
If your vendor has not been listed, there are several options:

● Change the MAC addresses of the replaced AP one-by one using the Generic - one MAC
Replaced vendor option .

● Use the Generic - Up to 16 Virtual MACs Replaced option to replace all the MAC addresses
automatically. This option should be used if the last hex number (4 bits) of the MAC address
changes between different SSIDs.

● Use the Generic - Up to 64 Virtual MACs Replaced option to replace all the MAC addresses
automatically. This option should be used if the last 6 bits of the MAC address change between
different SSIDs.
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4.5.7 Adjusting the Properties of Measured Access Points
By deafult, the names of the measured access points are defaulted as the AP manufacturers. To
change the name, edit the text box.

Edit the AP notes by clicking on the note icon. This information may include AP mounting inform-
ation, name of the person responsible for installation, cabling information and so on. An empty
paper is displayed if there are no notes for the AP, and a paper with text will be displayed if notes
are written for the AP.

In some cases, the surveyed network shows high interference due to inoptimal channel selections
of the APs. Ekahau Site Survey allows you to simulate how interference (and thus, network per-
formance) would change if the AP channels were changed. To simulate a channel change for a
measured AP, simply click on the 802.11 channel selection drop-down menu and change the
channel. 802.11b band channels are presented in blue, 802.11g channels in green, 802.11a
channels in orange, and 802.11n channels in purple. The impact of the channel change will be
visualized on the map thereafter.

Figure 4.8. Channel selection view

1. 802.11g Band (Green)
2. 802.11n Band channel selection (Purple)
3. 802.11a Band (Orange)
4. 802.11b Band (Blue)
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Figure 4.9. Working with access points

1. The names of Cisco APs are automatically shown
2. Notes
3. Measured 802.11n properties
4. If "Selected Access Points" is selected, the visualization will be displayed only for selected

APs
5. This AP is selected - Select and de-select from here or from the map
6. Multi-MAC and SSID access point - This AP has three SSIDs and MACs
7. The channels of the AP - Click to see how changing the channel(s) would impact the network
8. Selected as "My" which means that this AP belongs to my network
9. Name (defaults to brand)

4.5.8 Adjusting the Properties of Simulated Access Points
For simulated APs, you can change the following parameters:

● AP Band: Whether the AP is 802.11a, 802.11b, 802.11g, or 802.11n. Select from the 802.11
technology button.

● AP Channel: The frequency channel the AP is operating at. Select from the channel button.
● APRadio Transmission Power: The transmission power at which the AP radio is transmitting

the signal. Click on the Edit... button and edit the text field to adjust.
● Antenna Type: Directly impacts the coverage area of an AP. Click on the Edit... button and

click on the drop-down menu to select an antenna.
● Antenna Height: The higher the antenna, the weaker the signal strength will be below the

AP. To adjust the height, click on the Edit... button and edit the height text field.
● Antenna down tilt: Some antennas are meant to be tilted down for optimal coverage. To

adjust the downtilt, click on the Edit... button and type in the downtilt in degrees to the textbox.
● Notes: Add text information about the access point.
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To edit the properties of multiple APs at once, select the simulated access points you would
like to edit, and click Actions > Edit Selected Simulated Access Points.

Figure 4.10. Adjusting simulated access points

1. 802.11 Technology (a/b/g/n)
2. Click on the Edit... button to adjust antenna properties
3. Tx Power, Height, and Antenna downtilt properties
4. Antenna type and its radiation patterns

E = Elevation Plane (Side View)
A = Azimuth Plane (Top View)

5. Channel
6. 802.11n properties

4.5.9 One Access Point, Multiple MAC Addresses
Many modern access points can be configured to broadcast several MAC addresses from a single
physical access point. An example of this feature is when an AP is configured for multiple SSIDs.
In order for Ekahau Site Survey to work properly in "multi-MAC environments", the MAC addresses
coming from a single AP should be joined together.

By default, Ekahau Site Survey automatically joins together all major Wi-Fi vendors' light-weight,
enterprise access points working on a multi-SSID. This option can be removed from Site > Auto-
Detect Multi-MAC Access Points. You can also adjust the auto-detection to only automatically
join only selected brands of access points.

To view all the (joined) MAC addresses one single AP broadcasts and their corresponding 802.11
technologies and encryption methods, click on the MAC address button.
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Figure 4.11. This single physical access point broadcasts three different MAC addresses and
SSIDs

Splitting Falsely Joined Access Points

There might be cases where Ekahau Site Survey falsely detects and joins access points as Multi-
MAC AP. This might be the case for example with some legacy Cisco access points. These falsely
joined APs can be recognized from oversized signal coverage and from multiple distributed high
signal strength peaks.

To split an falsely joined access point, click on the MAC address button of the falsely joined AP
on the AP List view and after that, click on the Split button of the MAC address you want to be
distinquished.

Figure 4.12. Splitting access points

4.5.10 One Access Point, Multiple Radios
In addition to combining MAC addresses, ESS combines automatically Cisco and Meru dual-radio
Access Points. For example, an access point with 802.11g and 802.11a radios are shown as a
single access point. You can alsomanually combine other vendors' dual-radio access points:

1. Select the two access points you want to combine from the AP list
2. Select Actions > Combine Radios

The two Access Points are now trerated as a single access point.
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Figure 4.13. Manually combining Multi-Radio APs

Note

TheCombine Radios selection will not be available unless you have exactly two radios selected.

Separating Falsely Joined Radios

If there are cases where the radios are combined mistakenly, you can separate them as follows:

1. Select the access point that has been falsely joined
2. Select Actions > Separate Selected Radios

Figure 4.14. Manually separating falsely joined radios

4.5.11 802.11n Characteristics
802.11n is the latest iteration of Wi-Fi, promising higher bandwidth up to 600Mbps, range, reliability
and throughput than its predecessors 802.11a/b/g standards. Some of the main technical charac-
teristics that enable these improvements in 802.11n are the number of Spatial Streams which is
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related to MIMO (Multiple Input Multiple Output), Extension Channel, Greenfield, and Short Guard
Interval (SGI):

Spatial Streams

In 802.11n the data stream is divided into multiple parts called spatial streams. Each spatial stream
is transmitted through separate antennas to corresponding antennas on the receiving side. When
the number of spatial streams is doubled from one to two, the maximum data rate is also doubled
from 150Mbps to 300Mbps. With three spatial streams it is possible to achieve 450Mbps data rate
and with four spatial streams 600Mbps data rate.

Extension Channel

The 802.11n's optional extension channel is used to double the available bandwidth to achieve
higher data rates. This is done by bonding two channels to occupy 40MHz channel width. In legacy
802.11 Wi-Fi networks, the typical channel width is 25MHz. Thus, there is a good chance that the
40MHz extended channel overlaps with some nearby legacy Wi-Fi networks enough to cause
interference. It is highly recommended to use extension channel only in 5GHz frequency band
due to the limited number of non-overlapping channels available in 2.4GHz frequency band.

Greenfield Mode

The Greenfield mode is used to improve efficiency in pure 802.11n networks by eliminating the
unnecessary support for 802.11a/b/g devices. When this mode is enabled, only 802.11n clients
can access the network. Thus, if you have legacy 802.11 clients that cannot access the network,
make sure that you have this mode disabled.

Short Guard Interval (SGI)

Guard Interval defines the time between each district data transmissions. It is used to ensure that
the district transmissions in the network do not interfere with each other when there are propagation
delays, echoes, and reflections. Typically the guard interval should be two to four times the
transmission delay spread. In 802.11a/g networks, the (long) guard interval is 800 ns allowing 200
ns delay spread. By shortening the guard interval it is possible to increase throughput of the network.
Most office and home environments have much smaller delay spread than 200 ns, typically 50-
100 ns. Thus, Short Guard Interval of 400 ns can boost the throughput by avoiding unnecessary
idle times in the network.

4.5.11.1 Measured Access Points
Ekahau Site Survey can measure the 802.11n characteristics during site surveys. To view the
characteristics of an 802.11n AP, click the 11n button on the Access Point List view.

Figure 4.15. 802.11n characteristics
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In the above example, the AP with Cisco: A307 SSID has bonded two channels, 52 and 56 where
the channel 56 is the extension channel. The AP has SGI enabled, Greenfield mode disabled, and
it uses two spatial streams.

4.5.11.2 Simulated Access Points
The 802.11n characteristics can also be adjusted when working with simulated 802.11n access
points. To adjust the characteristcs of an 802.11n AP, click the Edit... button of the simulated AP
on the Access Point List view. Note that access points with multiple radios need to be adjusted
one radio at a time.

Figure 4.16. Adjusting 802.11n characteristics of an simulated access point

4.6 The Surveys List
Figure 4.17. Surveys list

Every time you stop a survey (by right-clicking the mouse when surveying), a Survey will be added
to the Surveys list. The Surveys list will show the name of the survey, as well as the map the survey
was performed on.

Using the Surveys list, you can select and de-select the surveys. If you want to visualize the network
coverage and performance for specific surveys only (such as only the surveys that have been
performed recently), simply de-select the other surveys. To select, de-select, and delete multiple
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Surveys, simply select more than one Survey, right-click on one of the surveys, and select the
desired action from the context menu.

Similarly to access point notes, you can also write down notes for each survey. Simply click the
note icon to edit the survey notes.

4.7 The Building View
The building view is only necessary when creating three dimensional network plans. For information
on how to use the Building View, see chapter Designing a Wi-Fi Network.

4.8 Menus

Use the menus to access file operations, site specific operations, zooming and more.

DescriptionSelectionMenu

Create a new ProjectNewFile

Open an existing ProjectOpenFile

Save the Project using the existing
file name

SaveFile

Save the Project using a different
file name

Save AsFile

Export the Project as an XML fileExport as XMLFile

Import floor maps from Cisco Prime
NCS / WCS

Import Maps from Cisco NCS/WCSFile

Export either Planning or Site Sur-
vey project to Cisco Prime NCS /
WCS

Export to Cisco NCS/WCS File
Format...

File

Export the currently displayed map
image and visualization

Export ImageFile

Print the currently displayed map
image and visualization

Print ImageFile

Generate a report of the networkReportFile

Merge another Project with the cur-
rent Project

MergeFile

Change the product preferences,
such as the length unit

PreferencesFile

Exit the programExitFile

Undo the previous actionUndoEdit

Redo the undone actionRedoEdit
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DescriptionSelectionMenu

Zoom in to see an area in more
detail

Zoom InView

Zoom out to see a wider area of the
map at once

Zoom OutView

Fit the map into the windowZoom to FitView

Zoom to see the map in its actual
pixel size

Zoom 1:1View

Show or hide the survey routesSurveysView

Show or hide the GPS Reference
Points

GPS Reference PointsView

Show or hide the access point iconsAccess PointsView

Show or hide the access point
names

Access Point NamesView

Show or hide the Floor Alignment
Points

Floor Alignment PointsView

Show or hide the WallsWallsView

Show or hide the Coverage AreasCoverage AreasView

Add a map to the ProjectAdd MapSite

Make a duplicate of the currently
displayed map

Duplicate MapSite

Change the currently displayed map
image

Change Map ImageSite

Remove a map from the ProjectRemove MapSite

Select the currently displayed mapActive MapSite

Edit the network coverage and
pefromance requirements

Edit RequirementsSite

Edit the network capacity require-
ments

Edit Capacity RequirementsSite

Open Auto-Planner dialog and
choose network requirements for
the network simulation

Start Auto-PlannerSite

Automatically place the access
points (that were detected during
the survey) on the map

Locate Surveyed Access PointsSite

Clear all AP locations from the mapClear Surveyed Access Points Loc-
ations

Site

Automatically detect access points
distributing multiple MAC addresses

Auto-Detect Multi-MAC APsSite

Edit Replaced Access PointsEdit Replaced Access PointsSite

Edit text notes about the ProjectEdit Project NotesSite
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DescriptionSelectionMenu

View the currently audible Wi-Fi
signals, and quickly troubleshoot
issues without a map

Live Network StatusDevice

Shows the currently connected Wi-
Fi devices

DevicesDevice

Open the Quick GuideEkahau Site Survey Quick GuideHelp

Open the User GuideEkahau Site Survey User GuideHelp

See product information, upgrade
license

About Ekahau Site SurveyHelp

Shows the latest features introduced
into the current Ekahau Site Survey

What's NewHelp

Sign up for the ESS mailing listSign Up for Update NotificationsHelp

4.9 Software Preferences

To adjust software preferences, go to File > Preferences. The preferences include:

● Changing the length unit (meters / feet)
● Setting the regulatory domain to limit network adapter scanning
● Enabling or disabling Real-Time Location Tracking System features
● Enabling or disabling automatic map scrolling while surveying
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5 Starting to work with Ekahau Site Survey

5.1 Starting Ekahau Site Survey
After the installation, ensure the following before starting Ekahau Site Survey:

● For traditional passive surveys: A supported Wi-Fi adapter is enabled and connected to your
laptop (Visit http://www.ekahau.com/devices for the list of supported adapters)

● For Hybrid Surveys: A supported external Wi-Fi adapter is connected to your laptop and a
supported integrated Wi-Fi adapter is enabled and associated with a Wi-Fi network using the
Windows Wi-Fi Management tool

● All other programs are closed
● You are logged in as the computer administrator, or have administrative privileges

To start Ekahau Site Survey, click Start > Programs > Ekahau > Ekahau Site Survey.

5.2 Setting the Map and Scale

The functionality of the program mostly relies on the floor plan(s) of the facility. You will need to
insert at least one map and set its scale. For multi-floor buildings, add multiple maps, one for each
floor.

Note

Even though map images with 10000 x 5000 pixels are supported, they are not recommended
to be used as this slows down the software. For optimal performance, please use maps smaller
than 4000 x 4000 pixels.

To insert a map, click Site > Add Map or click the + sign next to the map selector. Alternatively,
you can also import the floor maps directly from Cisco Prime NCS / WCS control system by
selecting File > Import Maps from Cisco NCS/WCS.

The following image formats are supported for maps:

● BMP, WBMP
● JPG, JPEG
● PNG
● GIF
● SVG (SVG drawings)
● DWD, DXF (2D CAD drawings)

Note

Only two dimensional (2D) CAD drawings are supported. 3D drawings are not currently supported.
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You also need to set the scale for each map. To set the scale, you need to know the distance
between two points on the map. It is recommended to use a measuring tape to measure the distance
between the points. Once measuring the real-world distance, set the scale in ESS:

● Select the scale tool
● Indicate the distance between the two points by clicking the first point, and holding down the

left mouse button while moving the mouse pointer to the second point
● You will see a line between the two points, and a tooltip indicating the number of pixels. Click

on the tooltip on the ft / m field and type in the distance between the two points in feet or
meters.

Figure 5.1. Use common objects whose width / length is typically known such as doors to set the
correct scale

1. The door width is 1 meter / 3.3 feet which in this map image corresponds to 50 pixels.

Tip

To set the length unit between feet and meters, go to File > Preferences.

Note

It is highly important to set the correct scale! Otherwise some visualizations and simulations
may not be shown correctly.

5.2.1 Changing the Map Image

In some cases, the underlying map image used needs to be changed, without losing all the infro-
mation about the surveys or about the predictive design. To change the underlying map image,
go to Site > Change Map Image.
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Note

The replacing map image needs to be of the same size and scale as the original map image.

5.3 Defining Network Requirements
Each Wi-Fi installation is different. Whether the network is used for e-mails, voice over Wi-Fi, or
location tracking, the application determines what is required from the network. Ekahau Site Survey
allows you to set the Coverage, Performance as well as the Capacity requirements for the network.
With a single view you can see if those requirements are met.

5.3.1 Coverage and Performance Requirements
In Ekahau Site Survey, you set the following Coverage and Performance criteria to be monitored:

● Signal strength (minimum signal strength for the strongest AP)
● Signal-to-noise ratio (minimum SNR, given a minimum allowed data rate in the network)
● Data rate (minimum)
● Number of audible APs (the minimum number of audible APs, given a minimum signal

strength)
● Ping Round Trip Time (minimum round trip time for ping)
● Packet Loss (packet loss %, calculated from the last 10 packets)

In addition to requirements, you can choose the following conditions that affect on the network
coverage and performance:

● Use Noise from (the source of the noise data - choose either Measured Data, Simulated
Interference or Automatic which uses Measured Data when available )

● Network load (the estimated amount of wireless traffic in the network - available only if sim-
ulated noise is selected)

● Adapter (the end users' wireless adapter)

To define the Requirements, select Site > Edit Requirements.
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Figure 5.2. Setting the wireless network requirements using the Requirements dialog

The Requirement defines what your network is used for. You can either select one of the pre-
defined Requirements, such as Basic Connectivity or Voice over WLAN. If none of the Requirements
matches the purpose your network will be used for, you can either customize the existing profiles
or create new ones. If you want to keep the existing Requirement, and want to make a slightly
different one, you can make a duplicate of the selected Requirement. The requirements are
explained in more detail in chapter Visualizing Network Coverage and Performance.

5.3.2 Capacity Requirements
Ekahau Site Survey takes the capacity of the Wi-Fi network fully into consideration. With the
increasing number of smartphones, laptops, and tablets constantly utilizing the Wi-Fi network,
capacity needs to be considered during network design, verification, and troubleshooting. ESS
can accurately analyze the network capacity based on the number of Wi-Fi devices, and the
applications run on them.

The Capacity Requirements are considered inCapacity Health andAssociated Clients visualizations.
If you are trying to view them not having the Capacity Requirements defined, Edit Capacity
Requirement dialog will pop up and lets you define the requirements. To define the Capacity
Requirements:

1. Select Site > Edit Capacity Requirement... if do not have the edit dialog already open
2. In the edit dialog, define the number of different client devices in the Wi-Fi network
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Figure 5.3. Edit Capacity Requirement - Add Different Client Devices

3. If you want to prepare times for unusually high network utilization, adjust the Peak Network
Usage slider - This will multiply the amount of traffic in the wireless network

4. Optionally adjust the applications used on the devices by clicking the pen icon

Figure 5.4. Edit applications run on the client devices

5. Select each applications that are run on the client device as well how long they are being
used during 8 hours

Figure 5.5. Adjust application usage run on the client device

Note

The configured client devices will be distributed evenly between the floor maps according to
the surveyed data. You should limit the area of client devices by using Coverage Areas (Planning
tab).
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6 Designing a Wi-Fi Network

Note

The network design capabilities are only available in Ekahau Site Survey Pro version. You may
skip this chapter if you want to directly perform to performing site survey, or troubleshooting.

When designing a new Wi-Fi network, Ekahau Site Survey is able to create a network plan for you
automatically. In ESS this feature is called asAuto-Planner. The Auto-Planner saves you significant
amounts of time by cutting down the manual work of placing access points and configuring their
channels by hand.

Prior to deploying a Wi-Fi network with the Auto-Planner, you will need to indicate the coverage
area(s) where you need Wi-Fi coverage. In addition, you will need to draw walls for the coverage
area(s) so that ESS can calculate the optimal AP locations and configuration(s). In case you want
to deploy a network plan for multi-floor building(s), please refer to chapter DesigningWi-Fi Networks
for Multi-Floor Buildings on page 44 for more information on how to define multi-floor buildings.

Proper network planning will reduce costs in the long run, and will lead to better coverage and
performance also. After creating the network plan, you will know:

● The optimal locations for your Wi-Fi access points
● Antennas and their alignment
● Optimal AP configurations, such as transmission power and channels
● The predicted coverage and performance of your network

Figure 6.1. A network plan with walls, simulated access points, and floor alignment points
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Note

If you leave the access point transmit power settings to Automatic Radio Management (Radio
Resource Management, Radio Management) from your wireless LAN management software,
using the default 25mW transmit power is recommended when creating simulated APs .

6.1 Creating a Network Plan with Auto-Planner

Note

You can use the Auto-Planner only with empty projects. In case there are simulated access
points in the project, the Auto-Planner will clear them from the project. The auto-planner will not
take in account recorded survey data either. Thus, the Auto-Planner cannot be used for network
expansion.

In order to create an accurate network plan, you will need to have the map(s) and scale(s) set.
You will also need to define the main walls of the building. With this information, ESS can calculate
the Wi-Fi signal propagation. Once the environment has been defined as well as the desired cov-
erage area, you can use the Auto-Planner to create the network plan. Alternatively, you can create
the network plan by yourself by placing and configuring simulated access points. Both methods
are explained in detail in the following chapters. For more information on how to add maps and
how to set scales, please refer to chapter Setting the Map and Scale on page 31

6.1.1 Drawing and Editing Walls
To define the environment, you will have to draw walls. To do this, you will need to go to the
Planning tab and select the Wall tool. First, you will need to select the wall material that most
closely matches the wall you're going to draw. To draw the walls, simply keep left-clicking on the
map. If you want to end the wall drawing, just right-click.

You can edit the walls that you have drawn by first selecting the Edit tool and left-clicking the wall
you want to edit. You can edit multiple walls at the same time by holding down the Ctrl key while
selecting the walls. To edit the wall(s), simply drag-and-drop the wall(s) to its new location. You
can also change the wall material by right-clicking the wall and selecting Change Wall Type.

Note

By default, the walls are drawn in 15 degree angles. To draw walls in any angle, hold down the
Ctrl key while drawing walls.
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6.1.1.1 Customizing the Wall Materials
If you want to customize the wall materials, you will need working knowledge of XML or HTML,
and a plain text editor. The wall materials are specified in the wallTypes.xml file, located in the
conf folder under the product installation folder. To edit the wall materials, open the wallTypes.xml
file with a plain text editor, and add, remove or edit the wall materials. The tags are explained in
the table below:

DescriptionTag

An identifier for the wall material. Needs to be unique for each material.id

The name of the wall material, displayed in the user interfacename

The width of the wall materialwidth

The absorption factor of the wall material, in dB per meterabsorption

The color of the wall material, represented as hex triplets. For more
information, see http://en.wikipedia.org/wiki/Web_colors

color

When inserting new wall materials, you will need to measure the signal strength both in front and
behind the wall. Subtract the former from the later and you will get the signal loss in dB. Then
measure the width of the wall, and calculate the absorption factor by diving the signal loss with
the wall width in meters. Insert the new wall material into the conf file, save the file, and re-start
ESS.

Note

It is recommended to make a backup copy of the wall materials list before editing it.

6.1.1.2 Duplicating Maps with Similar Layouts
If several floors have similar or fairly similar wall layouts, it is recommended to duplicate the map
to avoid unnecessary drawing of walls. When you duplicate a map, the map image and the walls
will be duplicated. This allows you to only draw the walls to a single floor, and use the same wall
structure for the other floors. If the floors are slightly different, it may still be easier to duplicate the
floor and then edit the walls for the areas that are not similar. Click Site > Duplicate Map to make
a duplicate of the map.

6.1.2 Indicating Network Coverage Areas
In order to create the automated network plan, you will have to define the network coverage area
where you would like to have Wi-Fi coverage. To do this, use the Coverage Area tool in the Planning
tab to indicate the areas where you need Wi-Fi coverage. When using the tool, left-click to add
points to the polygon, and right-click to end the polygon.
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Figure 6.2. Coverage Area and Auto-Planner buttons

1. Click the Coverage Area button to define network coverage areas
2. Click the Auto-Planner button to open network requirements dialog and to create the network

plan

Figure 6.3. Drawing the network coverage area

1. When you are drawing the network coverage area, the currently selected area will be displayed
as lilac

2. After you have drawn the desirable network coverage area, it will be bordered with a dash
line and the lilac colour will disappear
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6.1.3 Configuring Auto-Planner
After you have defined the network coverage areas, click the Auto-Planner button to open the
Auto-Planner dialog where you can select the Network Requirement, Access Point type as well
as Channel Assignment.

Figure 6.4. Auto-Planner dialog

1. Choose the network requirement type for your plan - You can select from one of the predefined
requirements or define your own requirement - How to edit or define your own network
requirements is explained in more details in chapter Defining Network Requirements on page
33 - Note that the in Auto-Planner only the Signal Strength and Number of APs requirements
are taken in account

2. Select the Wi-Fi band, either 2.4 GHz or 5 GHz - If you want to optimize your network for 5
GHz Wi-Fi band, the network will be more dense than for 2.4 GHz

3. (Optional) Define the capacity requirements for the network. Check the Consider in plan
checkbox and a dialog for editing the capacity requirements will pop up. For more information
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on editing the capacity requirements, please refer to chapter Capacity Require-
ments on page 34.

4. Select the Access Point type you want to use in the network plan as well as Transmit power,
Antenna height, and 802.11n characteristics

5. Define the Channel Assignment you want to use for your network plan - You can select a
predefined channel assignment, just a single channel for example if you are using Meru Access
Points, or none meaning that you will assign the channels after the network plan has been
deployed

After you have defined the requirements for you network plan, click the Create Plan button to
deploy the network plan. The plan will be deployed for all floors in the building where you have
defined the coverage areas. For separate floor maps that are not defined as a building, the network
plan needs to be deployed separately for all floor maps.

If you are not satiesfied with the network plan, you can just re-run the Auto-Planner with a different
Requirement, Access Point type, and/or Channel Assignment. Every time you re-run the Auto-
Planner, it will clear the previous Access Point layout(s) and the AP configurations. Alternatively,
you can manually change the location of the Access Point(s) with the Select tool or add more
simulated access points. For more details on how to work with simulated access points, please
refer to chapter Creating the Network Plan Manually Using Simulated Access Points on page 42.

Figure 6.5. An example Wi-Fi network plan created with the Auto-Planner - This particular network
plan is optimized for Location Tracking

6.2 Creating the Network Plan Manually Using Simulated
Access Points
Before you can start working with simulated access points, you need to define the environment
which includes adding the necessary maps, defining the scale, and drawing walls. How to draw
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walls is explained in more details in chapter Drawing and Editing Walls on page 38. After the
environment has been defined, you can start simulating your network to find out the optimal network
configuration.

To start predicting the network performance, place one or more simulated access points on the
map:

1. Select the Simulated Access Point Tool from the Planning Tab
2. Choose the access point you want to simulate. You can simulate either a pre-defined AP or

a customized AP with a particular antenna.
3. Place the access point on the map with a left-click. If Always Refresh Automatically visualization

option is enabled, you should instantly see a visualization for the placed access point.
4. Click either the Edit button on the AP list or the technology/channel rectangle on the right-

hand side of the AP on the map to edit its properties - You can select the technology, channel
and adjust the AP transmission power, AP height, and antenna downtilt - The Elevation Pattern
presentation of the antenna displays the beam towards the floor
If you are simulating a 802.11n AP, you can also edit the Extension channel, # of Supported
Spatial Streams, Greenfield, and Short Guard Interval properties.

5. Repeat steps 2-4 to place more access points

Figure 6.6. Editing simulated access point

1. Click to edit a simulated access point

You can adjust a non-omnidirectional AP's orientation. Click and hold the small yellow triangle on
top of the AP icon until you find the correct orienation.

Figure 6.7. Adjusting AP orientation

You can move a simulated access point by simply dragging them on the map when the Edit tool
is selected (hold down the left mouse button while moving the AP).

To delete a simulated access point, right-click on the access point on the map and select "delete".
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After placing the APs on the map, the properties of the APs can be changed using the AP list.
Refer to the chapter User Interface Overview to read more about changing the properties of the
access points that have already been placed.

6.2.1 Optimizing Access Point Layout and Configuration
There are several ways to find the optimal number, placement and configuration for your APs.
Here's one recommended method:

1. Set the maps, scale, walls, and optionally building layout and floor alignment points
2. Select Network Health for My APs, and select the appropriate Requirement
3. Start placing access points and configuring them. Use the Network Health visualization to

see if the network meets your requirements. If it does not, use the Network Issues visualization
to see what the problem is. If it is low signal strength or overlap, add more access points or
move the existing access points.
If the problem is low signal-to-noise ratio, or low data rate, the problem may be in the channel
separation - there is probably just too much channel interference. Optimize the channel sep-
aration by adjusting the channels of the APs - for 802.11b/g, channel separations such as 1-
6-11, 1-4-8-11, 1-5-9-13, or 1-7-13 are typically recommended.

4. Continue until you have found a satisfactory wireless network.

6.3 Designing Wi-Fi Networks for Multi-Floor Buildings
In multi-floor buildings, signals propagate through floors, just like they propagate through walls. It
is essential to take this into account when designing Wi-Fi networks, as the floor-to-floor signal
propagation can be used to your benefit: You may need less access points as an access point on
the floor above or below may cover an area that would have need an additional access point oth-
erwise.

However, the signals penetrating floors may also harm the network performance if there is co-
channel interference created between access points on nearby floors. This must be accounted
for also in the network design.

To simulate a multi-floor model in ESS, you will need to define the building layout (the floor
order, height, and floor material), and set at least three Floor Alignment Points per floor.
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6.3.1 Defining the Building Layout
Figure 6.8. A sample building view enabling 3D planning for two floors

1. Select building
2. 3D planning status indicator
3. Add / Remove buildings
4. Floor material
5. Map image
6. Add / Remove floors
7. Floor height

To define the building layout, go to the Building tab in the left-hand side lists.

1. Assign a map image with the floor: You will need to select the appropriate map image for
each floor. It is important to note that the lowest floor is on the bottom in the Building view. A
single map can only be assigned for one floor.

2. Select a floor material: Select the floor material that best matches your environment.
3. Set the floor height: Measure the height of the floor (from floor to ceiling), and set it.

A status indicator at the top of the screen will assist you in defining the building layout. Once the
status indicator states OK, you will be able to see the simulated AP signals penetrating the floors.

Use the Actions button to add buildings. This allows making network plans for multiple buildings
within a single project.
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6.3.2 Setting Floor Alignment Points
Map images between floors may differ in terms of rotation, and offset, for example. To align the
floors for 3D prediction, you will need to use Floor Alignment Points.

You will need to find three locations in the building that are identifiable at each floor. Stairwells,
elevator shafts, building corners, and building pillars are good examples: Typically they are in the
same locations on each floor. These will serve as your Floor Alignment Points. To mark them:

1. Select the map you want to place the Floor Alignment Points to
2. Select the Floor Alignment Point Tool in the Planning Tab
3. Optionally name the floor alignment point, such as "Staircase West"
4. Place the floor alignment point on the map by left-clicking.
5. Repeat steps 2-4 so that each map has at least 3 Floor Alignment Points.

Figure 6.9. Two floors of a building with alignment points correctly placed in the same locations
in both floors

Note
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The floors that are connected to each other need to share three reference points. If you use
reference points in different locations for different floors, ensure that each floor is connected by
a minimum of three reference points.

6.3.3 Visualizing Floor-to-Floor Signal Coverage
To visualize how access points are audible from one floor to another:

1. Ensure from the Building tab that your 3D propagation model has been correctly defined
2. Clear the AP selections by clicking Actions > Select None
3. Select a floor that you want to see the signals radiating to
4. Using the AP list, select the access points that are of interest (for example, the access points

on the floor above and floor below the floor you're currently looking at)
5. Select Show Signal Strength for Selected Access Points. If any of the APs on the floors

below and above are audible to this floor, you will see their coverage.
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7 Site Surveys - Ensuring Sufficient Coverage and
Performance On-Site

7.1 Performing Site Surveys

With Ekahau Site Survey, you simultaneously perform traditional passive surveys as well as active
surveys - this is called Hybrid Survey. Passive surveys measure signal strength, SNR, and other
information, whereas active surveys measure end-to-end connectivity.

During the active survey, an end-to-end connection is made to a specific host, ensuring that the
network truly works and delivers the required performance. The end-to-end network connectivity
testing can be used for:

● Detecting significant latency - Excellent for investigating latency-sensitive applications such
as VoIP over WLAN

● Detecting dropped packets - Solve problems possibly caused by low coverage, roaming
issues, and hardware defects

● Visualize roaming areas - Visualize which AP the Wi-Fi adapter was connected to in different
locations

During the traditional passive survey, signal readings from all the audible access points are
measured and all the audible access points will be discovered and added to the AP list. In addition
to the access points in your network, you are likely to discover other access points as well: some
may be audible from the neighboring office or even the neighboring building, and some may be
"rogue" access points placed in your environment without authorization.

To perform a Hybrid Survey, you will need two Wi-Fi network adapters. Please visit
http://www.ekahau.com/devices for the list of supported adapters. The external network adapter
(such as Ekahau NIC-300) will be used to capture passive signal readings whereas the integrated
Wi-Fi adapter will be used for the end-to-end testing. The integrated Wi-Fi adapter has to be
associated with a Wi-Fi network and the network has to allow ICMP echo requests (Ping).

To perform a Site Survey:

● Ensure that both of your wireless network adapters (external & integrated) have been enabled
in your laptop. Check the Miniature Signal View to see if the external network adapter is suc-
cessfully scanning access points. Alternatively, you can use your integrated network adapter
to scan access points when not performing end-to-end connectivity testing.

Figure 7.1. The Miniature Signal View should show signals updating before starting the survey.

● If you are using an inappropirate driver with your external adapter, a warning will be given.
To achieve the optimal accuracy, use the driver provided by Ekahau. For information on how
to update the driver, see chapter Wi-Fi Network Adapter Driver Update.

Figure 7.2. A warning will be given if an inappropriate driver is used.
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● When testing the end-to-end connectivity, ensure that you are able to collect Ping data. The
Miniature Ping View will displayNo Ping Hostmessage if valid Ping Host has not been found.
By default, the Ping Host is Default Gateway, but it can be changed by clicking the Miniature
Ping View.

Figure 7.3. No Ping Host message will be displayed if valid Ping Host has not been set.

● Click the Record Survey button. ESS will start the end-to-end connectivity testing automatically
if the internal Wi-Fi adapter has been enabled for Hybrid Survey and valid Ping Host has been
found / set.

Figure 7.4. Miniature Ping View displaying successful Ping packets (green) vs. lost packets
(red).

● Click your current location on the map to start collecting signal information as well as end-to-
end connectivity measurements.

● Start walking at a slow, steady speed. Click the map whenever you start or stop walking, and
whenever you change your speed or direction.

● Right-click the map when you want to finish the current survey and continue from another
location.

● Release the Record button when finished surveying.

Note

Ekahau Site Survey automatically scrolls the map when you click your location close to the edge
of the screen. You can disable this feature from File > Preferences.

The data is recorded continuously during a Survey, not just when you click on the map. The data
will be interpolated on the map between two mouse clicks. If you do not stop at any point, but
rather continue walking when reaching a given point, you only need to click on the map once at
every turn. If you stop somewhere for more than one second, you should click on the map when
you arrive, and click again on the same location as you leave. The upside of the continuous
recording is that you gather more data during your survey. In addition, you only need to click twice
(at the beginning and at the end) when walking a straight line, such as a hallway.

If SSID Broadcast has been disabled in the access points, the SSID will not be detected by ESS.
However, the MAC address and other information of the AP will still be detected. Enabling at least
one SSID to be broadcast for the duration of the site survey may help in organizing and selecting
the access points.

ESS continuously monitors how your network performs against the network requirements. The
Miniature Requirement View displays the network's current status where you are and indicates if
some of the network requirement criteria is not met. This allows you to react on network problems
while you are performing the survey. For example, you may notice that your network does not
meet the Location Tracking requirements and adding more access points is required. This prevents
you performing unnecessary surveys until more APs has been added.
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Figure 7.5. Miniature Requirement View displaying the Signal Strength and Number of APs criteria
failing in Location Tracking requirement - Click the view to change the requirement

Tip

Keep the surveys fairly short to allow more flexibility for deleting and modifying the survey
data. An optimal survey length varies from a few rooms to a wing of a building. Right-click to
end the survey every now and then, and continue surveying by simply left-clicking on the map
again. There is no need to manually create a new survey - the current survey is ended with a
right-click, and a new survey is created automatically when you continue surveying.

Warning

Do not insert or remove network adapters or other devices during the survey.

7.1.1 Configuring the Wi-Fi Device for Passive Surveys

To configure your Wi-Fi device, go to Device > Devices or click the Network Adapter Settings
icon. From the Devices Window, you can see the connected Wi-Fi devices, their status and device
information. To activate a different Wi-Fi device, select the adapter from the Devices list and click
Activate. To configure the signal scan settings of the selected Wi-Fi adapter, click Scanning
Configuration.

On the Scanning Configuration tab, you can to configure which channels to scan. You can either
select to scan all channels on 2.4GHz and/or 5GHz frequency band or select particular channels
to scan. Scanning just one frequency band or limiting the number of scanned channels reduces
the overall scan time, which allows more data to be collected over time, which in turn, allows faster
site surveys.
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Figure 7.6. The Scanning Configuration Tab

Note

The scan settings cannot be configured for all Wi-Fi devices. For example, the scan settings in
the built-in Wi-Fi adapter of an Intel Centrino cannot be configured.

7.1.2 Configuring the Wi-Fi Devices for Hybrid Surveys
The end-to-end network performance testing is always made with the laptop's integrated Wi-Fi
network adapter. The integrated network adapter has to be connected to the Wi-Fi network to be
able to measure the network performance. To connect, use Windows Wi-Fi Management tool.

By default, Ekahau Site Survey pings the Default Gateway. You can change the Ping Host by
clicking the Miniature Ping View icon. To ensure the defined Ping Host replies to ping, click the
Start button. It is not necessary to leave the Ping enabled as ESS will enable it automatically when
you start recording Hybrid Surveys.
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In Hybrid Survey mode, the traditional signal measurement is always made with the external Wi-
Fi adapter. To configure the external Wi-Fi adapter, please see chapter Performing Site Sur-
veys on page 49.

7.1.3 Moving and Deleting Survey Points

After the survey, it may be necessary to move or delete Survey points - perhaps because the
location was not clicked properly in some locations. To move or delete Survey Points, right-click
on a survey point and select Move Survey Point or Delete Survey Point. When you delete a Survey
point from a survey, the Survey will be split into two.

7.1.4 GPS Assisted Outdoor Site Surveys
ESS allows you to use a GPS handheld to perform site surveys outdoors, without having to click
on the map. For example, by connecting a GPS receiver to your Wi-Fi enabled laptop, you can
simply drive around the coverage area of a municipal Wi-Fi network, and ESS will automatically
plot the route on the map in addition to taking the Wi-Fi measurements.

7.1.4.1 Supported GPS Receivers
A GPS receiver is required for the GPS survey feature to work. The following GPS receivers are
supported:

● Bluetooh GPS devices, that support NMEA
● USB GPS devices that support NMEA, Garmin Protocol or Trimble TAIP
● Network connected GPS devices (usually using TCP/IP or UDP), that supports TAIP or NMEA
● GPS devices connected to PC-CARD that supports NMEA
● GPS devices that are connected to an RS-232 port, that support NMEA, Garmin or TAIP

Note

To perform GPS assisted site surveys, you will have to have Franscon GpsGate installed on
your computer which can be installed during ESS installation. If you have not or do not want to
install the GpsGate during ESS installation, you can later install it from Ekahau Site Survey
program menu: Start > All Programs > Ekahau > Ekahau Site Survey > Installa GPS Support

GPS Navigators are typically not supported, even if they have a USB connection.

7.1.4.2 Performing GPS Assisted Surveys
To perform an outdoor survey using GPS:

1. Connect a GPS receiver to your laptop
2. Turn on the receiver, make sure it is outputting data in one of the supported formats. You will

need to be outdoors for the GPS receiver to work properly.

Chapter 7. Site Surveys - Ensuring Suffi-
cient Coverage and Performance On-Site

53



3. In the user interface, check the Use GPS checkbox. If you do not see the Use GPS checkbox
in the top-right corner of the user interface, ensure that you have purchased ESS Professional
version.

4. If your GPS device has not been previously configured, a GPS configuration dialog will pop
up.
Typically, the default settings are recommended.
When asked "Do you want to use this device", select Yes.
In the output selection, ensure that the "share my GPS between several applications" option
has been selected.

5. ESS needs to be able to transform the GPS coordinates into map coordinates. For this, you
will need to place three GPS Reference Points on the map.
To place the Reference Points, use the GPS Reference Point Tool on the Survey tab. Click
on the map to place a GPS Reference Point. When placing the Reference Points, you will
need to either know the latitude/longitude coordinates for the Reference Point location, or
alternatively be physically located there with your GPS receiver turned on, in which case the
coordinates will be taken from the GPS receiver. Repeat until you have three reference points
on the map.

6. Now you should see the blue circle on the map, indicating your current location. If it is not,
check if you see an exclamation mark next to the Use GPS button. If so, move your mouse
over the exclamation mark to see the error.

7. In the Survey tab, click the GPS Record button to start the survey.
8. Drive or walk throughout the outdoor area you wish to survey.
9. End the survey by clicking the GPS record button again.

Note

If the GPS device is not detected, re-try the GPS device detection. If the GPS device is not
detected after several retries, try using the advanced options to adjust the GPS configuration
to your needs.

Note

To ensure measurement accuracy, take the reference points at least 300 meters (1000 feet)
apart from one another, and don't place the reference points on a straight line.

Tip

Using an external antenna for the Wi-Fi network adapter improves the outdoor survey accuracy.

7.2 Post-Deployment and Pre-Deployment Surveys
Post-deployment surveys are performed after the complete network is already in place. Post-
deployment surveys are used for network verification immediately after the network has been
deployed, and for periodic checks to ensure the network is still operating at a required level. The
periodic maintenance surveys may cover the entire area or just parts of it, whereas the verification
surveys done immediately after the network has been built usually cover the whole desired coverage
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area. To perform post-deployment surveys, no specific actions need to be taken - just survey as
specified in the previous section.

Pre-deployment surveys are used for on-site validation of network plan. In pre-deployment sur-
veys, you would use one or few access points to ensure the network coverage and performance
on-site - prior the complete network has been deployed. Simply move the AP(s) between the
planned locations and make a survey whenever the AP has been moved.

To simulate a complete network with a limited number of access points in the pre-deployment
survey phase, use the Freeze Access Point tool. The Freeze Access Point tool allows a single
access point that as been placed in several locations to be treated as multiple access points. Using
Freeze AP, you can individually visualize and analyze each location where the AP was placed. If
Freeze AP is not used, you would simply see one AP detected, and be able to visualize one huge
coverage area. Moreover, it allows simulating a complete network in terms of overlap, channel
interference, and data rate, by using just one or a few access points.

To use Freeze AP:

1. Turn on the access point
2. Perform a survey within the coverage area of the access point
3. Stop surveying, and unplug off the access point
4. From the user interface, select the access point (and only that access point) and selectActions

> Freeze Selected Access Points
5. Move the access point to the next location
6. Repeat steps 2-4 until all the necessary AP locations have been surveyed

Note

Although the previous instructions are for one access points, several access points can also be
used in the pre-deployment survey, and several access points can be frozen at once.

7.3 Placing Access Points on the Map

Ekahau Site Survey is able to place access points on the map automatically after the survey.
These are estimated locations. You can disable the feature by unchecking the "Auto-Place APs"
checkbox during the survey. If you have disabled the Automatic Placement, you can manually
force the automatic on-demand placement of access points from Site > Place Access Points
Automatically.

The AP locations guessed by ESS may not be exact. You can move the AP to its exact location
by simply dragging the AP to the desired location when using the Edit tool. After an AP has been
manually moved, the Auto-Locate features will not try to locate the AP any more. Also, if you exit
the program or re-open the project, the current AP locations will be fixed, and the Auto-Locate
features will not try to locate those APs any more. However, all the newly discovered APs will still
be automatically located.

The Automatic Placement will only try to locate the access points that are well audible (surveyed
signal strength has exceeded -50dBm in one or more locations). This is to avoid locating the access
points inaccurately.
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To place an AP that has not been automatically placed, just drag and drop the AP from the AP list
to the map.

To find the position of a single AP, click on the "Drag on the map to place" text in the AP list and
select Automatically Place Access Point.

7.4 Selecting My Access Points
After the surveys have been completed, and you have located your access points, you should
indicate which APs actually belong to your network. My access points are defined by using the
"My" checkbox in the AP list. By default, all the APs are checked as My. You need to uncheck the
APs that are not a part of your wireless network.

Warning

IMPORTANT: If your My APs are not properly selected, the visualizations as well as many other
features will not work properly.

To learn more about My Access Points, see chapter Selecting My Access Points.

7.5 Simultatenous Survey Work: Merging Two Projects
as One

If several persons are surveying the areas at one time, the results need to be merged as one in
the end. The Merge feature imports surveys, access points, walls, everything in the Project To
merge two or more files as one:

● Open the first Project
● Select File > Merge
● Browse for the second Project which needs to be merged with the first one
● If more than two surveyors have been on the field, repeat the previous step for all the Projects

Warning

In many cases, some access point locations are lost in Merge. Always check the AP locations
of the Merged file and make the necessary corrections.

Note

The Merge feature does not Merge surveys within the same map. The surveyors need to operate
on different floors (maps) for the Merge to work properly.
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7.6 Inspecting Surveys in More Detail
In some cases, if network is not behaving normally, the signal behavior may need closer inspection.

During the survey, the network adapter keeps constantly scanning the network for signal readings
from the access points. To see the individual signal measurements on the map, select the Survey
Inspector tool. To view the individual measurements and analyze the survey data in more detail,
double-click on the position of the survey route you want to inspect, or right-click on a Survey in
the Surveys list and select Inspect. A Survey Inspectorwindow will open, displaying the recorded
signal readings in the point nearest to the clicked location as well as measured Round Trip Time
(Ping) and the associated Access Point during the measurement. An orange dot on the map will
indicate which measurement point is currently analyzed.

The window will also show the recorded data over time for a given survey. Use the Next and Pre-
vious buttons to move to the next and previous survey point along the survey path. To analyze
the measurement data for select access point(s), highlight the APs on the AP list in the dialog.

Figure 7.7. Survey Inspector allows you to analyze the signal behaviour in more detail

1. Signal behaviour over time for the selected access points
2. These signals were heard at the highlighted point on the graph
3. Ping / Round Trip Time graph displaying the latency at the selected time interval
4. The time window shown in the graph
5. Move to next signal measurement
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8 Analyzing the Wi-Fi Coverage and Performance
There are various visualizations that allow you to estimate network coverage and performance.
The visualizations are displayed as "heat maps" on the map image.

The displayed visualization is selected using the two drop-down menus above the map window.
The default visualization is Signal Strength for My Access Points. The first drop-down menu selects
the visualization type, for example signal strength or data rate. The second drop-down selects
what access points will be included in the visualization. If you want to visualize signal strength for
one access point only, for example, you would select Show Signal Strength for Selected Access
Points and just select the AP you want to see the signal strength for. The AP can be selected
either from the map, or from the AP list.

When the visualization is displayed, roll over the map with the mouse to see the actual values on
the map at a given point as a tooltip.

Figure 8.1. Visualization view

1. Visualization type
2. Visualized access points
3. Refresh visualization button - Uncheck the box to manually refresh the visualization
4. Visualization options
5. Visualization
6. Editing legend

Note
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Automatic refresh option refreshes the visualization automatically when changes are made.
Automatic refresh works well for small and medium-sized projects. If you are working with a
large project, you may want to disable the automatic refresht to keep the software running
smoothly, and only refresh the visualization when needed.

For quick reference for visualization, see the tables below.

PurposeVisualization

What is the estimated data rate (in Mbit/sec) for the
clients

Data Rate

How bad is the co-channel interference (in dBm)?Interference / Noise

Does the network meet your requirements?Network Health

If requirements are not met, what is wrong?Network Issues

How many APs are audible in each location?Number of Access Points

How good is my signal coverage (in dBm)?Signal Strength

How much stronger is the useful signal than the co-
channel interference (in dB)?

Signal-to-Noise Ratio

What is the strongest access point at each location?Strongest Access Point

What is the network latency between a client and host?Ping / Round Trip Time

What is Packet Loss %? (Calculated from the last 10
packets)

Ping Packet Loss

With what Access Point was the client associated with?Associated Access Poin

Where has 802.11n Channel Bonding been enabled?802.11n Channel Bonding

PurposeVisualize for

Display the visualization for all the access pointsAll access points

Display the visualization only for the APs checked as
"My"

My Access Points

Display the visualization only for the APs NOT checked
as "My"

Other Access Points

Display the visualization only for the APs selected from
the list or the map

Selected Access Points

Note

In order to see any visualization, surveys need to be recorded, or at least one simulated access
point needs to be placed on the map.
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8.1 Visualization Options
Visualizations contain parameters that can optionally be set using Visualization Options. Some
visualization options are specific to the selected visualization, whereas some are generic and
apply to all the visualizations.

The Visualization Options allow you to set parameters concerning the visualization accuracy,
performance and overall appearance:

Figure 8.2. Some visualization options are generic, some are visualization specific

1. Visualization Mode - See the visualization in Smooth mode (polygons) or Detailed mode
(rectangles)

2. Extrapolation - When Smooth Visualization Mode is selected, adjust the level of extrapolation
in meters/feet

3. Speed vs. Accuracy - Allows the visualizations to be refreshed more quickly at the expense
of the accuracy, or vise versa

4. Signal Prediction - Enable or disable all signal prediction. Can be used to predict signal
propagation through other floors

5. Visualization specific options (In this case for Signal Strength visualization)

8.1.1 Visualization Mode
The visualization heat maps are overlaid on the map using some amount of extrapolation, because
every inch of the facility can not be surveyed. To adjust the amount of extrapolation, click the
Options button next to the visualization selection.

There are two Visualization Modes:

● Detailed: The extrapolation is fixed. The Detailed Mode provides low extrapolation and
accurate results. Does not allow adjusting the amount of extrapolation of data. Use Detailed
mode when in-depth analysis is needed.
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● Smooth: Adjustable amount of detail, as the user can set the extrapolation (in feet or meters).

Figure 8.3. Visualization modes and extrapolation slider

Figure 8.4. Detailed and Smooth visualization modes

When designing large Projects with lots of walls and simulated access points, you may want to
get visualizations updated quickly to find out the optimal number of access points, their locations
and configurations as quickly as possible. At this point, the accuracy of the visualization may not
be essential to find out the "ball park" locations and configurations of access points.

In situations like these, you can increase the visualization speed by adjusting the slider above the
Signal Prediction options. The Rough Sketch will provide the fastest response with the least amount
of detail, whereas the Very Accurate setting will provide most detail, sacrificing some of the response
time.

Figure 8.5. Visualization speed vs. accuracy slider
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Figure 8.6. Very Accurate Mode (on the left) and Rough Sketch Mode (on the right)

8.1.2 Signal Prediction
It may not always be feasible or even possible to survey all areas and rooms of the project. Instead,
signal prediction can be used. There are two main types of signal prediction in ESS:

● Signal prediction of simulated access points: All signals from the simulated APs are predicted.
● Signal prediction of measured (surveyed) access points: The signals outside the surveyed

areas are predicted.

Ekahau Site Survey can predict signal propagation through floors. There are five options to choose:

● Off - No signal prediction is used at all
● Currect floor - Signal propagation in current floor is only predicted
● One floor - Signal propagation to one floor above and below is predicted
● Two floor - Signal propagation to two floors above and below is predicted

Figure 8.7. Signal Prediction options

By default, Signal Prediction is enabled. If it is necessary to see only the measured (surveyed)
data of the access points, and disregard all the prediction calculations, disable Signal Prediction.
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Figure 8.8. Viewing a measured access point with signal prediction (on the right) and without (on
the left)

8.1.3 Visualization Specific Options
Some visualizations have specific options that only apply for them. These visualization specific
options include:

● MinimumSignal Strenght - The visualization is only shown in areas where the signal strength
exceeds this threshold

● Adapter - The visualization is shown according to how the selected adapter would have per-
ceived the measured data

● Network Load - Is used with simulation visualizations to demonstrate how different network
loads affects on the network performance

● Use Noise From - Defines wheter the visualization uses measured Noise or Simulated Co-
Channel Interference - With Automatic option, the measured Noise is always used when
available

● Show <xx> Strongest Signal at <xx> Channel - Visualizes the selected strongest signal at
the selected channel(s)

8.2 Adjusting the Legend
You can adjust the visualization appearance and value range by adjusting the Legend. The Legend
can be adjusted by clicking on the Legend at the bottom-right corner of the screen. The Legend
adjustments are automatically saved with the project. The following adjustments are provided:

● Contours: The contour line between each color in the visualization can be enabled or disabled.
● Value Range: Adjusts the range of values to be displayed. The Open setting at each end of

the value range allows you to see the values outside the value range also.
● Spacing: Each color in the visualization may represent one or many values. The spacing

controls how many values each color represents.
● Colors: Select the desired color range from the drop-down menu.
● Requirements: Since the colors for these visualizations are fixed, and the results of Network

Health and Network Issues visualizations depend on the Requirements, clicking the Legend
when these visualizations are enabled allows you to edit the Requirements.
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Figure 8.9. Adjusting the legend has a significant impact inn the visualizations

Not all options are customizable for all visualizations. The table below explains the visualization
default values and adjustment options:

Default ValuesLegend Adjustment OptionsVisualization

From 1Mbps up to 600MbpsContours On / OffData Rate

-100dBm through -50 dBm or MoreValue Range, Spacing, Colors, Contours On / OffInterference

Pass / FailRequirementsNetwork Health

Pass / FailRequirementsNetwork Isseus

1 through 10 or more APsValue Range, Spacing, Colors, Contours On / OffNumber of APs

-80dBm through -20 dBm or moreValue Range, Spacing, Colors, Contours On / OffSignal Strength

0dB through 50 dB or moreValue Range, Spacing, Colors, Contours On / OffSignal to Noise Ratio

MAC addresses of the APsContours On / OffStrongest Access
Point

0.0 ms throught 1000.0 msContours On / OffPing / Round Trip
Time

0 % through 100 %Value Range, Spacing, Colors, Contours On / OffPing Packet Loss

AutomaticContours On / OffAssociated Access
Point

On / OffContours On / Off802.11n Channel
Bonding
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8.3 Visualization Views

8.3.1 Data Rate
Data Rate is the is the speed at which the client device and the access point are communicating
at. The higher the data rate, the more data is expected to be transferred between the client device
and the access point in a period of time. In 802.11, the advertised data rate is the theoretical
maximum at which the devices are able to communicate. However, the net data throughput between
two devices is typically less than half of the advertised data rate.

In ESS, the data rate is calculated using the following Visualization Options as parameters:

● Network Load affects the data rate: The higher the network load, the more interference. The
more interference, the lower the SNR, and the lower the SNR, the lower the data rate.

● Different Adapters have different receiver sensitivity capabilities, and even support different
802.11 standards. Thus, using different adapters may have a significant impact to the data
rate . For example, an 802.11b adapter can only communicate at a maximum of 11Mbps.

Note

The data rate is calculated only for access points that are marked as My APs. If you are visual-
izing with Selected Access Points view, the APs that are currently Selected will work as sources
of noise.

66Chapter 8. Analyzing the Wi-Fi Coverage
and Performance



Figure 8.10. Data Rate visualization

1. No data transfer possible
2. High data rate (54Mbps)
3. Low data rate
4. Red = 1Mbps <-> Green = 54Mbps

8.3.2 Interference / Noise
Co-channel interference and other noise may have an impact on Wi-Fi performance. Ekahau Site
Survey shows interference / noise levels in two ways:

● As measured by the Wi-Fi adapter
● As calculated co-channel interference

By default, ESS uses the noise measured by the Wi-Fi adapter when visualizing surveyed data,
and when a fully supported external adapter is used for site surveys.

You can make adjustments to the noise visualization from Visualization Options.
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Note

A Wi-Fi adapter is not an accurate interference / noise measurement device. For accurate noise
measurements, please use the Ekahau Spectrum Analyzer (see http://www.ekahau.com/spec-
trum).

Figure 8.11. Interference visualization

1. High interference
2. Low interference
3. Very low or no interference
4. Adjust interference visualization value range, colors, etc.

8.3.3 Network Health
Network Health provides a summarized overview of the network. It shows whether all of your
network requirements (see also chapter Defining Network Requirements) are met or not. If one
or more of the network requirements are not yet, Network Health will fail, and red color will be

68Chapter 8. Analyzing the Wi-Fi Coverage
and Performance



displayed for those areas. If all of the network requirements are met, green color will be displayed.
To adjust the requirements, click on the color legend, or click Site > Edit Requirements.

Figure 8.12. Network Health visualization

1. Network meets requirements
2. Network does not meet requirements
3. Select requirement
4. Click to adjust requirement

8.3.4 Network Issues
If one or more of your network requirements are not met in one or more locations (see also Network
Health), the Network Issues visualization will display which requirement fails. If more than one
requirement fail, only one failing requirement will be displayed.
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Figure 8.13. Network Issues visualization

1. Insufficient signal strength
2. Network meets requirement
3. Not enough audible access points
4. Insufficient Signal-to-Noise Ratio
5. Select requirement
6. Click to adjust requirement - Each network issue is represented by a color

8.3.5 Number of APs
The Number of APs visualization shows how many access points are audible in a given location.
The number of APs must be sufficient to ensure sufficient overlap in the network. Overlap is needed
for seamless roaming between access points, as well as load balancing.

The following selections will affect the Number of APs:

● Minimum Signal Strength allows you to set a minimum signal strength for an AP that is to
be included in the number of APs to be visualized. For example, if you set it to -90, the number
of APs audible at stronger than -90dBm signal strength will be shown.
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● Adapter affects the Number of APs visualization, as some adapters are more sensitive, and
can thus hear more APs in a given location than the others.

Figure 8.14. Number of APs visualization

1. No audible APs
2. Lots of audible APs
3. Only 2 audible APs
4. Click to adjust the visualization value range, colors, etc.

8.3.6 Signal Strength
The Signal Strength visualization displays the signal strength of the selected set of access points
in dBm. By default, the signal strength of the strongest access points per location will be displayed.

Signal Strength has the following options accessible via Visualization Options:

● Viewed Signal allows you to disregard the signals from the strongest access points, visualizing
the second or third strongest signals instead of the strongest one. This is useful for visualizing
AP failover scenarios and redundancy.

● Signals at Channel limits the Signal Strength visualization to only show the signals at a
selected channel.
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● The Adapter selection allows you to visualize the signal strength as the selected adapter
would "see" it. For example, the signal strength may be sufficient using a high-quality network
adapter, but may not be sufficient using a wireless VoIP phone with different antenna charac-
teristics.
Ekahau Site Survey has characterized and field-tested various wireless adapters and VoIP
phones to allow accurate simulation when deploying wireless networks for different adapters.

Figure 8.15. Signal Strength visualization

1. High signal strength
2. Low signal strength
3. Signal strength below -80dBm
4. Click to adjust signal strength visualization value range, colors, etc.

8.3.7 Signal-to-Noise Ratio
The Signal-to-Noise Ratio visualization displays how much the signal strength is stronger than the
noise. With ESS, the noise is either noise level measured by the Wi-Fi adapter (if available), or
calculated co-channel interference.

Signal must be stronger than noise for data transfer to be possible. If the signal is just barely
stronger than noise, you may encounter occasional connectivity drop-offs.
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You can make adjustments to the SNR visualization from the Options drop-down window.

Figure 8.16. Signal-to-Noise Ratio visualiation

1. Low SNR
2. High SNR
3. SNR below 0dB (Noise level greater than signal level)
4. Click to adjust SNR visualization value range, colors, etc.

8.3.8 Ping / Round Trip Time
Ping is perhaps the most common tool for ensuring the network is working by measuring the network
latency. During the Hybrid Survey, the ESS sends ICMP request packets to the target host, which
by default is Default Gateway, and listens for ICMP response packets and measures the Round
Trip Time (RTT) of the packets.

The visualization displays the Round Trip Time of the Ping packets over the floor map. The visu-
alization varies from 0.0 ms to 1000.0 ms. When the RTT approaches 1000 ms, the users may
experience the network connection quality as decreased having problems from low quality VoIP
calls to slow file / Internet browsing. The Legend of the visualization is not customizable.
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Figure 8.17. Ping / Round Trip Time visualization

1. In this area the Round Trip Time has been 2.0 - 4.0 ms
2. Click to enable or disable Contours
3. Survey route

8.3.9 Ping Packet Loss
When ESS measures the network performance by pinging the target host, it measures the number
of lost packets at the same time. Packet Loss occurs when ESS fails to receive a ICMP response
packet to the ICMP request packet from the target host. The Packet Loss can be caused by several
factors such as interference and / or congestion in the network medium, corrupted packets, faulty
network hardware, or faulty network drivers.

The Ping Packet Loss visualization displays the relative Packet Loss % over the floor map. The
Packet Loss % is calculated from the 10 last packets.
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Figure 8.18. Ping Packet Loss visualization

1. Ping Packet Loss: 0 % - 10 %
2. Ping Packet Loss: 50 % - 60 %
3. Ping Packet Loss: 90 % - 100 %
4. Click to adjust the visualization value range, colors, etc.

8.3.10 802.11n Channel Bonding
To better visualize your 802.11n network characteristics, use the 802.11n Channel Bonding visu-
alization to see in which areas Channel Bonding is used to achieve higher bandwidth and to
recognize the area where it could be enabled.
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Figure 8.19. 802.11n Channel Bonding visualization

1. 802.11n Channel Bonding enabled
2. 802.11n Channel Bonding disabled
3. Click to enable or disable visualization Contours

8.3.11 Maximum Throughput
The Maximum Throughput visualization displays the theoretical maximum net throughput
(excluding network overhead) per location, given ideal circumstances and a single user accessing
the network.
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1. Moving the mouse cursor over each are displays the maximum throughput - In this case the
maximum throughput is 96-98Mb/s

2. Click to enable or disable Contours

8.3.12 Associated Access Point
The Associated Access Point visualization dpredicts where the client devices will be associated,
or, if Hybrid Site Surveys have been made, displays the actual associated access point throughout
the survey. The visualization is especially handy for recognizing roaming behaviour such as with
which access point the wireless network adapters typically associates in each area. Thus, you
can use the visualization to recognize areas where you might want to consider re-positioning
access points for better load balancing.
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Figure 8.20. Associated Access Point visualization

1. Moving the mouse cursor over each area displays the MAC address and SSID of the Access
Point the client adapter was associated with

2. Each roaming area is represented with different colors
3. Click to enable or disable Contours

8.3.13 Capacity Health
The Capacity Health visualization displays whether the network meets the Capacity Requirements.
If you have not defined the Capacity Requirements, a dialog for editing the requirements will pop
up. You can also edit the requirements by clicking the Legend. The visualization will display in red
and green colors if the Wi-Fi network will be able to support all devices and the application run on
them. For more information on editing the capacity requirements, please refer to chapter Capacity
Requirements on page 34.
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1. Insufficient capacity to support VoIP calls
2. Capacity requirement passed
3. Insufficient capacity for the required devices
4. Number of associations exceeded
5. Click the Legend to edit Capacity Requirements
6. Displays how many each device types there are on selected floor map and how many there

are in total in the network

8.3.14 Associated Clients
The Associated Clients visualization displays how the end user devices would be distributed
between the access points. The visualization helps finding the problem spots in the network, such
as an AP serving an overly large area, thus trying to serve too many clients.
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1. Less clients associated with this Access Point
2. More clients associated with this Access Point
3. Displays how many each device types there are on selected floor map and how many there

are in total in the network
4. Click the Legedn to edit Capacity Requirements

8.4 Different Survey Methods vs. Visualizations
Not all visualizations are available with just passive surveys, or when working with simulated
access points. The visualizations that require Hybrid Surveys do not work for simulated data. The
Network Health and Network Issues visualizations provide all the functionality only when using
Hybrid Surveys

The below table outlines which survey methods affect on each visualization:

SimulationHybrid Survey (End-to-
end Connectivity Test-
ing)

Passive Survey (Tradi-
tional Signal Reading)

Visualization

XXXData Rata

XXXInterference / Noise

XXXNetwork Health

XXXNetwork Issues

XXXNumber of APs

XXXSignal Strength
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SimulationHybrid Survey (End-to-
end Connectivity Test-
ing)

Passive Survey (Tradi-
tional Signal Reading)

Visualization

XXXSignal-to-Noise Ratio

XPing Round Trip Time

XPing Packet Loss

XXX802.11n Channel Bond-
ing

XXXMaximum Throughput

XAssociated Access Point

XXXCapacity Health

XXXAssociated Clients
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9 Troubleshooting - Detecting and Solving theMost
Common Wi-Fi Problems

9.1 On-Spot Troubleshooting Using Live Network Status
Ekahau Site Survey provides excellent tools for visualizing and troubleshooting your network on
the map - we will cover these later in this chapter. However, Ekahau Site Survey also provides a
powerful troubleshooting tool called Live Network Status. It works without a map, without having
any surveys performed.

In a typical troubleshooting scenario, the wireless network does not function in one or more locations
for some reason at a particular time. With ESS, you need to take the laptop to the problematic
area, and use the Live Network Status view to troubleshoot the issue. You can use the pre-defined
Requirements to see whether the network meets different application requirements or not. To start
the Live Network Status, click Device > Live Network Status, or click on the Miniature Signal
View.

9.1.1 Signals
The Signals tab of Live Network Status displays the current signal measurements from all audible
access points. Click Reset to clear the list of currently audible APs.

Figure 9.1. Signals view displays all currently audible access points

9.1.2 Requirements
The Requirements tab of Live Network Status compares your network requirements with the current
network measurements. If the network requirements are met at the moment, green color will be
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shown for each measurement. If your network requirements are not met right now, red color will
be shown for that requirement.

You need to choose the access points that are considered yours when using the Live Network
Status for troubleshooting. If you have not defined My APs (for example when using Live Network
Status on a blank Project without any surveys performed), choose Identify My Access Points
by SSID and select the SSID of your network. If you are working on an existing project with My
APs defined, select Identify My Access Points by Access Point List. If you do not choose either,
all of the APs will be considered to belong to your network - which may lead to overly optimistic
results.

Figure 9.2. Quick on-spot troubleshooting without a map

Note

To be able to compare Ping / Round Trip Time and Packet Loss measurements, the Ping tool
must be started. To do this, go to the Ping tab and click the Start button. Remember to make
sure you have valid Network Host configured.

9.1.3 802.11n Details
The 802.11n includes several improvements that offer higher throughput, range, reliability, and
bandwidth than legacy 802.11 standards. However, sometimes these 802.11n settings may cause
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interference and/or other problems with legacy 802.11 networks and devices. The 802.11n Details
view is very helpful to identify problems related to 802.11n.

The view displays the current signal measurements from 802.11n access points including their
802.11n characteristics. With the 802.11n Details view it is possible to identify for example how
many spatial streams different 802.11n access points are using and which channels are bonded
thus consuming available channels from other access points and/or possibly even causing inter-
ference. The 802.11n Details view also displays whether SGI and Greenfield mode are used in
the network. For example, you can check whether Greenfield mode is enabled in some of the
802.11n access points when a 802.11g client can not access your 802.11n network. In this case
the Greenfield mode should be disabled.

Figure 9.3. LIve 802.11n network details

Note

The 802.11n details can also be viewed per each 802.11n AP by clicking their 11n button in
the Access Points list.

9.1.4 Ping
The Ping tab in the Live Network Status view allows testing connectivity between the Site Survey
laptop and a selected server. The ping host is user configurable. By default, the Default Gateway
is used as the ping host.

The Ping tool can be used without performing any surveys.
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Figure 9.4. Live Network Status with Ping tool

Note

You can define the target host as an IP address or as a host name. When performing Hybrid
Surveys, ESS will automatically start the Ping tool. There is no need for starting it separately.

9.2 Troubleshooting After the Survey
The amount of troubleshooting scenarios ESS can be used for is almost endless. Here we will
present a couple of the most common Wi-Fi problem scenarios, and how to solve them with ESS.
Unlike in the previous section, The scenarios in this chapter assume that a site survey has been
performed, as the troubleshooting happens using the map.

9.2.1 Finding Network Problems with a Single View
After having your Requirements set, simply use the Network Issues visualization to identify network
trouble spots. Select the appropriate visualization to look at a given network parameter in more
detail.

9.2.2 Basic Wireless Issues - Low Coverage, High Interference
Problems like low coverage and high interference are easy to identify and troubleshoot.
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With low coverage, identify the spots of low coverage by selecting Show Signal Strength for My
Access Points. After identifying the spots with low coverage, first check that all of your APs are
transmitting signals. If the APs are working properly, you may need to increase transmission power,
or add more access points to the problematic areas (recommended). To simulate how adding an
AP to the problematic area would impact the coverage and performance, use the Simulated
Access Point tool in the Planning tab to place a Simulated AP on the map.

Note

Drawing walls prior to placing Simulated APs is recommended.

To identify high interference or low Signal-to-Noise Ratio, use the respective visualizations. If SNR
is below 0, or interference is above -70dBm, issues are likely to occur. After identifying the issue,
ensure first that the channel separation of your network is optimal.

Nearby access points should not be on the same or nearby channels. If there rogue or neighbor
access points audible to your facility, check their signals and channels by selecting Show Signal
Strength for Other APs. Use the Signals at Channel visualization option to see which channels
are crowded. If you suspect that there is non-802.11 interference, such as cordless phones,
microwave ovens or other machinery in the area, use the Ekahau Spectrum Analyzer.

To optimize the channel separation, change the channels from your access points to more suitable
ones. This can be done for measured as well as simulated access points. When changing the
channels, the visualizations are updated appropriately (using Always Refresh Automatically visu-
alization option is recommended). Keep the Interference or SNR visualization active to see the
impact of changing the channels.

Tip

Go to Visualization Options to visualize the calculated co-channel interference instead of
measured noise when optimizing channel separation.

9.2.3 Misconfigured SSIDs
Sometimes in enterprise networks, the SSID configuration may not be correct for all the access
points. In many cases, some of the APs are missing a given SSID because of either human error
or an incomplete configuration update by the Wi-Fi controller.

The quickest way to resolve this is to check the number of SSIDs in your network. To check the
number of SSIDs, use the Quick Select button in the AP list. Select the desired SSID, and the
respective APs will be selected in the AP list. You will see a per-floor summary of how many access
points are selected per floor.

Note
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Alternatively to using Quick Select, you can type the desired SSID to the Search box in the
Access Point list. Only the APs with that SSID will be displayed, and a per-floor access point
count will be displayed, as well as the total number of searched access points.

Tip

You can also visualize the coverage easily per SSID by using Quick Select and selecting Show
Signal Strength for Selected Access Points.

9.2.4 Defective Access Points
Defective APs can be found after the survey by looking at the AP locations. If ESS has not dis-
covered any access points close to a location where an AP should be, the AP is probably broken.

Visualizing Signal Strength for My Access Points may also reveal a broken AP: If there is low
coverage near a location where an AP should be operating at, it's probably broken.

The third way of discovering broken APs is to use the AP list: Either use the Quick Select or the
Search box to select an SSID, and look at the total count of APs, or the count of APs per map in
the AP list.

Finally, the AP may provide good signal coverage, but the Ping Packet Loss may show 100 %
loss for the AP. In this case, check the cabling of the AP, as well as the AP bridging and VLAN
settings.

9.2.5 Rogue Access Points
ESS automatically locates access points after the survey. After identifying and selecting My APs,
the detected rogue APs will be the ones that are displayed in red color. If there are APs that are
not automatically located and are not a part of your network, they are probably not in your facility,
and may not be distributing strong enough signals to interfere with your network.

9.2.6 Misconfigured 802.11n settings
The 802.11n includes several improvements that offer higher throughput, range, reliability, and
bandwidth than legacy 802.11 standards. However, sometimes these 802.11n settings may cause
interference or other problems with legacy 802.11 networks and devices.

9.2.7 Connectivity and Latency Issues
After performing Hybrid Surveys, it's easy to find connectivity and latency issues. Use the Ping
Packet Loss and Ping Round Trip Time visualizations to identify such issues. The issues may be
caused, for example, by high interference, excessive network traffic, or bad configurations in the
APs or the wired network.
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9.2.8 Insufficient Capacity
Use Capacity Health and Associated Clients visualization to detect capacity issues such as
insufficient network capacity. Perform the capacity analysis after the pre-survey to identify areas
with insufficient capacity and see how the situation would improve by introducing additional access
points.

9.3 Troubleshooting Non-Wi-Fi Interference Using Spec-
trum Analyzer
Wi-Fi devices operate on license-free frequency bands. This means that these frequency bands
are not limited to Wi-Fi - devices other than Wi-Fi also operate on the same frequencies. Some
examples of non-Wi-Fi devices that may operate on Wi-Fi frequencies are:

● Microwave ovens
● Wireless video cameras
● Wireless headsets
● Cordless phones
● Zigbee (IEEE 802.15.4)

Figure 9.5. Interference caused by a wirelesss video camera on 2.4 GHz frequency, as seen by
a spectrum analyzer

1. Interference intensity in dBm
2. Interference on Wi-Fi channels 1-3
3. Wi-Fi channels

Ekahau Site Survey uses the Wi-Fi adapter to take signal measurements. In cases where the
interference is caused by a non-Wi-Fi device, the interference issues may not be detected by the
Wi-Fi adapter. Connectivity issues caused by non-Wi-Fi interference may include:
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● Occasional, momentary connectivity cut-offs
● Low voice quality
● Lower than expected network performance
● One or more channels completely unusable momentarily or permanently
● Other suspicious network issues

For the reasons mentioned above, it is highly recommended to use a spectrum analyzer when
deploying or troubleshooting a wireless network. For Ekahau Site Survey users, using spectrum
analyzer is recommended in the following scenarios:

1. Network planning: Find out the interference sources before you deploy any access points
by making spot-checks with the spectrum analyzer around the facility - Detecting the interfer-
ence issues in advance may affect the access point placement and configuration

2. Network verification: A Wi-Fi site survey done with Ekahau Site Survey is always highly
recommended when verifying the network - This is typically done before the network production
use starts, and periodically (for example, every month) - During the verification check, you
may choose to perform spectrum analysis spot-checks at selected locations to ensure that
there are no significant interference sources present

3. Troubleshooting: The most common purpose for a spectrum analyzer is troubleshooting -
Whenever Wi-Fi issues arise that are not solvable with a Wi-Fi site survey, Ekahau recommends
using Ekahau Spectrum Analyzer - Typically, collecting a minute or two of data with a spectrum
analyzer will reveal the underlying issue

9.3.1 Using Ekahau Spectrum Analyzer
Firstly, you will need to insert the Ekahau Spectrum Analyser device to your computer, and install
the appropriate software. The spectrum analysis software is called Chanalyzer Pro. Consult the
Ekahau Spectrum Analyzer documentation for details on the installation.

To start spectrum analysis, click the Spectrum Analysis button. This will start the Chanalyzer Pro
software, assuming that it has been installed on your computer.

Figure 9.6. Ekahau Spectrum Analyzer - Chanalyzer Pro software quick launch

It is important to note taking measurements using a spectrum analyzer requires a method different
from Wi-Fi site surveys. Whereas during Wi-Fi site surveys it is acceptable to fairly quickly walk
around the facility taking measurements, spectrum analysis is something done in selected locations
only, spending more time (for example one minute) in a given location. This is because a spectrum
analyzer typically needs more time to collect meaningful data.

Prior to spectrum analysis, you will need to find out, whether the problems are on the 2.4 or 5GHz
frequency space. For example, if the problems are found with 802.11g VoIP phones, but not with
laptops operating on 802.11a, you should concentrate on analyzing the 2.4GHz frequency space.
Use the Configuration Side Bar (explained below) to configure the spectrum analyzer to scan the
appropriate frequency space.

User Interface

Ekahau Spectrum Analyzer - Chanalyzer Pro software has three main panes: Navigation, Over-
view, and Details.
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Figure 9.7. Chanalyzer Pro User Interface

1. Navigation Pane
2. Overview Pane
3. Details Pane

The Navigation Pane contains controls for browsing a Ekahau Spectrum Analyzer recording:

● Recording Navigator
A recording (or session) in Chanalyzer Pro can contain multiple captures changes in the
Ekahau Spectrum Analyzer or hardware configurations. The user can alternate between the
2.4GHz band and 5GHz band without creating additional and unecessary files. (The user can
also narrow in on a channel for detailed troubleshooting and have it be part of the recording
playback.) The recording will also contain all narrow band troubleshooting done during the
session.

● Timespan Controls
The Timespan controls in the navigation pane allow the user to adjust the length of time they
are viewing in the Overview and Details panes. Changing the time frame allows the user to
narrow in on anomalies and moments in time when the WLAN performed poorly.

● Playback Waterfall
The Playback waterfall displays ALL data in the Ekahau Spectrum Analyzer session with
visual indicators to show the section of time being displayed in the Overview and Details
section. The playback buttons are used to play, pause, jump back, and fast forward... to jump
to an arbitrary position in the session the user can double-click anywhere in the waterfall to
move the playhead to that point in time.

The Overview Pane contains the Waterfall and Density views and provide an overview of the
current time span:

● Waterfall
The Waterfall View graphs amplitude over time for each frequency in the band. The colors
represent power levels in the spectrum with dark blue as low; bright red as higher amplitude
levels—much like a doppler radar weather map. This view indicates the instances where
wireless devices like cordless phones or microwaves may have changed the spectrum. This
is an enhanced version of the highlighted green section in the waterfall navigation pane.

● Density
This views gives the traditional real-time spectrum view with a density map of the most used
points in th. The current, average, and max are 1 pixel lines drawn to show the current amp-
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litude of all signals, the average amplitude for all signals in the timespan and the max. These
can be toggled on and off by clicking the buttons above.
The Density View maps and displays how often a frequency/amplitude point is being used.
The less trafficked frequency ranges will appear more transparent. The colors represent
amplitude height with reds indicating higher signals and darker blues lower power levels. An
important feature of this view is that it picks up device-specific signatures which enables
analysis of what types of electronics are emitting RF energy in the area.

The Details Pane contains a number of tabs with more in-depth information about Wi-Fi networks
and their channels. You can quickly alternate between tabs by pressing CTRL + TAB:

● Networks Graph
The Networks Graph represents the Wi-Fi signal strength over time using data collected from
the computer’s Wi-Fi card. The signal strength represents the amplitude levels of transmit
beacons received by the card. Drops in signal strength indicate poor signal coverage, and
can be referenced against the spectrum data views (Waterfall and Density) to determine if
interference is at fault.

● Networks Table
The Networks Table is a list of the Wi-Fi access points that are within range of the computer’s
wireless card. The names (or SSIDs) of the APs are given along with signal strength (RSSI),
channel, Mac address and other identifiers. This table is used good for getting a snapshot of
what Wi-Fi networks are in the area as well as correlating RF activity as shown in the spectrum
views to known Wi-Fi networks.

● Device Finder
The Device finder is a signal strength over time graph similar to the Networks Graph, but it
shows the signal strength of the selected frequency range. Specify the frequency range by
using the mouse button to highlight a MHz range in the Density View. that has been chosen
in the Density view (click and drag in density view to see this).

● Channels Table
The Channels Table grades each Wi-Fi channel based on the RF activity within its given fre-
quencies and time range selected in the navigation pane. This table is primarily used in pre-
deployment of new wireless devices because it considers all RF noise occurring within Wi-Fi
channels whether it is Wi-Fi or non-Wi-Fi.
The Channel Grade is a weight for each freq/amp point based on how close it is to the center
of the channel and its amplitude.
The duty cycle is a relative score to help determine if a channel is usable or not. It measures
how much RF activity is occurring in the channel within the channels frequencies and the
specified time range in the navigation pane and is weighted so that signals near the center
of the channel have a greater effect on the duty cycle score.
The average is a measurement of the average power within the channel frequency range.
The max value is the highest amplitude point captured within the Wi-Fi channel frequency
range.

Finding Interference Issues

When using a spectrum analyzer, the goal is to find the interferers in the Wi-Fi frequencies. The
spectrum analyzer will display all the activity in the selected frequency space – meaning you will
see Wi-Fi activity as well as other activity. If you have already deployed Wi-Fi at the site, you will
need to be able to separate Wi-Fi signals from the actual interference. An example is shown in
the images below. The Chanalyzer Pro will automatically try to identify the interference source.
You can also use the Signatures tab in the right-hand side of the Chanalyzer user interface to see
how Wi-Fi compares to the other interferers.
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1. AV Transmitter on channel 1
2. An access point with ofi2 SSID on channel 1
3. An access point with testissid2 SSID on channel 6
4. An access point with testissid2 SSID on channel 11

Tip

For more information on how to use the Ekahau Spectrum Analyzer - Chanalyzer Pro softwared,
please refer to the Chanalyzer Help guide.
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10 Reporting, Exporting and Printing
With Ekahau Site Survey, you can easily output the network information by either generating a
comprehensive report, or by exporting or printing the images one-by-one.

10.1 Generating Reports
Generating a report constructs a comprehensive report in RTF or PDF format. To generate a
report, go to File > Report. From the dialog, choose the visualizations you want to be reported
and make the following selections:

DescriptionSelection

The output location of the reportFolder

The file name of the report, followed by the extension
(.rtf or .pdf)

File

The paper type of the reportPaper

Choose Adobe PDF, or easily customizable and MS
Word compatible RTF

Document Format

The title of the reportReport title

Choose an Image file, such as a company logo, to be
included in the front page of the report

Cover page image
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Figure 10.1. Generating reports

1. Renameable title of the report
2. Customizable cover page image - Click to change the image
3. Select the maps that should be included in the report
4. Select the visualizations and Access Points that should be included in the report
5. Choose the paper type and document format
6. Type the name of the report file and select where the report should be saved

The report includes:

● Access point configurations as a table
● Access point locations on the map
● Access Point Notes
● Network coverage and performance visualizations overlaid on a map
● Network Requirements
● Survey routes marked on the map
● Optionally an image in the front page
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10.2 Exporting and Printing Images
To export or print the currently displayed image, click File > Export Image or File > Print Image.

Note

Your current selections will impact the image: For example, if you have selected a visualization
for Selected Access Points, the exported or printed image will be constructed with the same
settings. What you see in the user interface is what will be exported or printed.
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11 Cisco Prime NCS / WCS Integration

11.1 Importing Floor Maps from Cisco Prime NCS / WCS
Since Ekahau Site Survey version 5.6, you can import the floor maps directly from Cisco Network
Control System (NCS). Also Cisco Wireless Control System (WCS) version 7.x is supported. To
be able to import a map you will need to have at least one access point deployed on the map.

To import maps from the Cisco NCS, select File > Import Maps from Cisco NCS/WCS. This will
open the import dialog. On the dialog, select the floor maps you want to import and click Import.
The map import utilizes the same building structure and map scale as defined in the Cisco NCS.
There is no need to define these separately in Ekahau Site Survey.

Figure 11.1. Map import dialog

If you try import maps that do not have any access points deployed, a warning will be given and
you will end up back to the map import dialog.

Figure 11.2. Error message if there are no Access Points deployed on maps you are trying to
import

The map import dialog will show which maps you have already imported to Ekahau Site Survey
and which maps were unavailable.
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Figure 11.3. Map import status

At this point, you can exit the map import dialog and go back to Cisco NCS. Add at least one
Access Point on the map to be able to import the floor map to Ekahau Site Survey. When you run
the map import dialog again, the dialog will display all the maps you have already imported.

Once you have imported all the maps you need, you can start the site survey.

Note

If the floor map scales are incorrect in Cisco NCS, the visualizations in Ekahau Site Survey may
be distorted!

11.2 Exporting the Project to Cisco Prime NCS /WCS File
Format
Ekahau Site Survey allows you to export your simulated network plan as well as the real-world
site survey data into a format that the Cisco NCS /WCS can utilize. With ESS you can create the
complete network plan for your Cisco environment including floor maps, Cisco AP locations and
configurations, and walls. The Site Survey data export is critical for many applications such for
calibrating the Mobility Service Engine (MSE) location application.

Current Restrictions

● Only projects with Cisco access points and antennas are supported when exporting a network
plan to Cisco Prime
* Other manufacturers' APs and antennas are not properly displayed in Cisco NCS / WCS

● Only site survey projects created from the scratch are currently supported
* You cannot export existing site survey projects - You will have to first import the maps from
Cisco Prime and then perform the site survey(s)

● Cisco WCS 7.0 or higher is required

To import the network plan or site survey project to Cisco NCS / WCS, you will first need
to create an export file

1. Select File > Export to Cisco NCS/WCS file format
2. Select either Export Plan or Export Survey Data to create the corresponding Cisco NCS /

WCS compatible export file
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Figure 11.4. Export to Cisco Prime NCS / WCS file format

3. Save the export file to your computer

Note

The Cisco Prime NCS / WCS site survey calibration requires that you have collected at least
150 survey data points at 50 distinct locations. This requirement is typically fulfilled during 10-
15min site survey. If you do not have enough survey data points, a warning will be given when
trying to export the survey data. If that happens, please gather more site survey data. In addition,
if no access points deployed in the Cisco NCS / WCS are observed during the site survey, the
site survey export is not possible.

Figure 11.5. An error will be shown during site survey export if there is not enough site survey data
to export or if no APs deployed in NCS/WCS are observed

11.3 Importing the Project into Cisco Prime NCS / WCS
No matter are you importing a network plan or site survey data into Cisco Prime, you will always
need to import the project file in the same way. Please follow the below steps to import your project
into Cisco Prime:

1. Login to the Cisco Prime control system
2. Go Monitor > Maps
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3. On the top right-hand side corner (-- Select a command --), select Import Maps and click Go

4. Select XML Formt and click Next

5. Choose the file and click Next
6. Scroll down the validation page and click Next
7. Finally, click OK
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11.3.1 Associating the Network Plan with the Actual APs
The steps 1-4 need to be repeated for all the maps in the building to associate the planned
access points with the physical access points that are active at the site:

1. Go back to Monitor > Maps
2. Navigate to the map you just added by clicking it from the left-hand side tree view

3. From the drop-down at the top-right corner (-- Select a command --), select Planning Mode
and click Go - A new browser window will open

4. In Planning Mode, select Planned AP Association
Repeat steps 5-6 for all the access points on the map:

5. From the drop-down at the top-right corner (-- Select a Command --), select Add AP Associ-
ation
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6. Select the planning AP, and below that, type in the base radio MAC address of the corres-
ponding physical access point

7. After you have done the above steps, go back to Monitor > Maps to see all the access points
in place

NOTE: Regarding to Step 6, if you do not know the base radio MAC, it can be found in NCS / WCS
as follows:

1. Go to Monitor > Access Points
2. Select an AP
3. Base radio MAC is listed in the general properties

11.3.2 Applying the Site Survey Data to the Cisco Floor Maps
Before the site survey data can be used in the Cisco Prime NCS / WCS by different applications,
the survey data needs to be applied to the floor maps (or to the RF Calibration Models to be precise).

1. Go back to Monitor > Maps
2. From the top right-hand side corner (-- Select a command --) drop-down menu, select RF

Calibration Models
Repeat the steps 3-8 for all the maps in the building to activate the RF Calibration
Models with the actual Site Survey data:

3. Click on the floor's Model Name whose RF Calibration Model you want to activate

4. On the top right-hand side corner, select Calibrate... from the drop down menu and click Go
to calibrate the floor with survey data
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Once the calibration is complete, its status will showCalibrated
5. On the top right-hand side corner, select Apply to Maps to apply the site survey calibration

to the map
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6. Select the correct Campus, Building, and finally the Map you want to apply the model

7. Click Apply
8. Once successfully applied, you can view the site survey calibrated heatmap for the map

Figure 11.6. Floor map with site survey data heatmap
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12 Real-Time Location Tracking (RTLS) Features
Assets and people can be accurately tracked using a standard Wi-Fi network to improve safety
and to locate assets quickly when necessary. Ekahau Site Survey fully integrates with Ekahau
Real-Time Location System. This allows you to use your existing site survey data to be used for
calibrating the location system. To enable the location tracking features, check the Enable RTLS
Features checkbox under File > Preferences. After re-starting the software, go to the Help menu,
and open the Ekahau Site Survey Guide for Deploying RTLS for more information about the RTLS
Features.

If real-time location tracking (RTLS) is of interest, visit www.ekahau.com to read more about
Ekahau RTLS, the industry-leading real-time location tracking system.

Note

If you have the RTLS Features enabled, but you do not use ESS to deploy Ekahau RTLS, you
may receive a warning about undefined Rails and Open Spaces when saving a survey project.
You can simply ignore this warning and choose Continue to save the survey project. However,
if you want to avoid this warning in the future, uncheck the Enable RTLS Features checkbox
under File > Preferences and re-start the software.
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13 Troubleshooting
This chapter includes some of the most common troubleshooting scenarios.

The program does not start or is very slow

● Ensure you have enough memory in your laptop, and that all other system requirements are
met

● Ensure you are logged in as the computer administrator, or have administrative privileges
● Ensure that the pixel sizes of the maps you have inserted are reasonable - preferably below

4000 x 4000 pixels
● Ensure all other programs are stopped when running Ekahau Site Survey
● Ensure that the scale has been set to each map
● If the program is running slow, disable Google Desktop, third party Virus/Spamware Scanners

(within reason - ensure your computer will not get affected) and other such applications

The software does not accept my license

● Ensure that you are connected to the Internet when starting the software for the first time
● Ensure you have the license for the correct software, and for the correct version
● Ensure the the same network adapter is in the computer which was registered when the

product was started for the first time
● Ensure the network adapter is connected and enabled when inserting the license
● Ensure the license you have has not been registered previously by anyone else
● The issue may be in the firewall or proxy. Try activating the license from another location.

I can't see any signals in the Miniature Signal View. In other words, the network adapter is
not scanning.

● Ensure your Wi-Fi adapter is enabled
● Ensure you have a supported Wi-Fi adapter. See www.ekahau.com/devices for details
● Ensure you have the correct network adapter driver installed. If using an external Wi-Fi adapter,

install the latest adapters from Start > Programs > Ekahau > Ekahau Site Survey > WLAN
Adapter Driver Installer If using the integrated Wi-Fi in Intel Centrino, use the latest available
driver from Intel

● Exit Ekahau Site Survey, remove and re-insert (or disable and enabled) the wireless network
adapter, then re-start Ekahau Site Survey

If the problem persists, contact support@ekahau.com.
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14 Additional Information

14.1 Meru Virtual Cell
The Meru Networks access points can operate in Virtual Cell mode. When in this mode, all the
access points broadcast the same MAC address. This is unlike other access points, that broadcast
at least one unique MAC address per access point.

Because of Meru Virtual cell, the mobile devices only see a single MAC address being distributed
by all the APs. Thus, the mobile devices think they're constantly connected to a single AP, even
though they are actually roaming between several APs. According to Meru, this makes the roaming
times shorted.

Because the MAC address is typically the unique identifier of an access point, most site survey
tools will not work well with Meru infrastructure - they cannot show per AP coverage or performance
maps, just one huge coverage area for all the APs. Unlike most site survey tools, Ekahau Site
Survey can read the "unique MAC addresses" of the Meru access points, which will allow the APs
to be displayed normally. Ekahau Site Survey displays the "Meru unique MAC addresses" instead
of the MAC addresses seen by other 802.11 clients. This feature is enabled by default and requires
no user intervention.

Note

The Meru Wireless Networks are designed so that all Wi-Fi access points operate on the same
channel. Therefore, when designing a network plan with Meru Access Points, set the Network
Load to zero in the Visualization Specific Options. This way the co-channel interference will
not be calculated.
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